aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-10-08 15:52:14 +0800
committerKhem Raj <raj.khem@gmail.com>2022-10-08 11:36:57 -0700
commit566606111626d697a18bb52e8db1283a30a2bb6c (patch)
treeb4ab41f53dd4f756174b2f1a621630b70bd31123 /meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
parentad0362ea2e274502a8ab62dbdd80550b40ba8f43 (diff)
downloadmeta-openembedded-566606111626d697a18bb52e8db1283a30a2bb6c.tar.gz
freeglut: upgrade 3.2.1 -> 3.4.0
Changelog: ========= Add GLUT_ACTIVE_SUPER modifier, and corresponding GLUT_KEY_SUPER_L and GLUT_KEY_SUPER_R special keys. Fix RGB mode (GLUT_RGBA) colors on 8bpp displays on windows (construct default RGB332 palette). Fix indexed color context creation on X11 and windows (GLUT_INDEX). Add missing colormap management functions for X11 and windows (glutSetColor, glutGetColor). Fix crash when calling glutTimerFuncUcall. Fix FreeBSD build by essentially disabling the joystick code for newer FreeBSD versions. Add fallbacks for the old GLX (<1.3) context creation API (glXChooseVisual/glXCreateContext) Add fallbacks for OpenGL 1.0 (no vertex arrays/client state). Use nanosleep instead of usleep on UNIX, which is more widely supported on old UNIX systems. Fix build on X11 if GL_SAMPLES is not defined. Fix overly strict context version checking on Android leading to context creation failure in some cases. Fix GLUT_CURSOR_INFO on windows, should be IDC_HAND, not IDC_HELP. Fix mismatched font declarations on X11. Add alternative simple ways to build freeglut with native tools only, without having to use cmake. Fix build on windows with cmake 3.0.0. Explicitly link with gdi32. Fix build on MSVC 2005. Fix build on MacOS X. Link with all the necessary X libraries. Fix build on SGI IRIX. Fix build on Android (mismatched function prototypes and missing glutCreateMenuUcall). Add support for the ninja multi-config generator. Removed spurious dependency on a C++ compiler. One of the demos was being compiled as C++ for no reason. Silence unnecessary warnings when VBOs or GLSL are not available. New demo programs: 3dview, keyboard, joystick. Documentation: added MacOS X build instructions. Made it possible to eventually support building freeglut as a single compilation unit Other minor fixes. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb')
-rw-r--r--meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb b/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
new file mode 100644
index 0000000000..627ce23544
--- /dev/null
+++ b/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "FreeGLUT is a free-software/open-source alternative to the OpenGL \
+ Utility Toolkit (GLUT) library"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=89c0b58a3e01ce3d8254c9f59e78adfb"
+
+SRC_URI = "https://sourceforge.net/projects/${BPN}/files/${BPN}/${PV}/${BPN}-${PV}.tar.gz"
+SRC_URI[sha256sum] = "3c0bcb915d9b180a97edaebd011b7a1de54583a838644dcd42bb0ea0c6f3eaec"
+
+inherit cmake features_check
+
+# depends on virtual/libx11, virtual/libgl
+REQUIRED_DISTRO_FEATURES = "x11 opengl"
+
+# Do not use -fno-common, check back when upgrading to new version it might not be needed
+CFLAGS += "-fcommon"
+
+PROVIDES += "mesa-glut"
+
+DEPENDS = "virtual/libx11 libxmu libxi virtual/libgl libglu libxrandr"