aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-01-15 10:47:30 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-22 12:22:34 +0100
commitd2cc10741b328725418af6ae121c935b54b1f0f6 (patch)
tree106206d98317d1b4b858be0a7b6061322e5e3546 /meta-oe/recipes-graphics
parentd096e77a362aba8bd70fc02413c16135bace7f7f (diff)
downloadmeta-openembedded-d2cc10741b328725418af6ae121c935b54b1f0f6.tar.gz
piglit: remove, migrated to oe-core
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/piglit/piglit_git.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/meta-oe/recipes-graphics/piglit/piglit_git.bb b/meta-oe/recipes-graphics/piglit/piglit_git.bb
deleted file mode 100644
index 7c4f9a00b9..0000000000
--- a/meta-oe/recipes-graphics/piglit/piglit_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-SUMMARY = "OpenGL driver testing framework"
-LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
-
-SRC_URI = "git://anongit.freedesktop.org/piglit"
-
-# From 2012/12/30.
-SRCREV = "bbeff5d21b06d37338ad28e42d88f499bef13268"
-# (when PV goes above 1.0 remove the trailing r)
-PV = "1.0+gitr${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-DEPENDS = "virtual/libx11 waffle virtual/libgl libglu python-mako-native python-numpy-native"
-
-inherit cmake pythonnative
-
-# CMake sets the rpath at build time with the source tree, and will reset it at
-# install time. As we don't install this doesn't happen, so force the rpath to
-# what we need.
-EXTRA_OECMAKE = "-DCMAKE_BUILD_WITH_INSTALL_RPATH=1 -DCMAKE_INSTALL_RPATH=${libdir}/piglit/lib"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 piglit-*.py ${D}${bindir}
-
- install -d ${D}${libdir}/piglit/
-
- install -d ${D}${libdir}/piglit/bin
- install -m 755 ${S}/bin/* ${D}${libdir}/piglit/bin
-
- cp -a lib/ ${D}${libdir}/piglit/
- cp -a framework/ ${D}${libdir}/piglit/
- cp -a generated_tests/ ${D}${libdir}/piglit/
- cp -a tests/ ${D}${libdir}/piglit/
- cp -a templates/ ${D}${libdir}/piglit/
-
- sed -i -e 's|sys.path.append(.*)|sys.path.append("${libdir}/piglit")|' ${D}${bindir}/piglit-*.py
- sed -i -e 's|^templatedir = .*$|templatedir = "${libdir}/piglit/templates"|' ${D}${bindir}/piglit-summary-html.py
-}
-
-FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
-
-RDEPENDS_${PN} = "python waffle python-json python-subprocess python-multiprocessing python-textutils python-netserver python-shell mesa-demos"