aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-28 13:49:59 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-28 14:32:06 +0000
commit3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch)
tree66dc67f338ba316c25ca672950ef334e9e357386 /meta-oe/recipes-graphics
parentd66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff)
downloadmeta-openembedded-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz
Replace bb.data.* with d.*
Used sed expression given here: http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html Plus an additional expression for .expand. Full expression is: sed \ -e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \ -e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \ -e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \ -e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \ -i `grep -ril bb.data *` Some minor correction in systemd.bbclass was needed for some expressions that didn't quite match the regex in the desired way; additionally a few instances were manually changed. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb4
-rw-r--r--meta-oe/recipes-graphics/pango/pangomm_2.28.2.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb2
3 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
index 8e842c48fe..3f6d7673ce 100644
--- a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
+++ b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
@@ -23,8 +23,8 @@ PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome"
PACKAGES_DYNAMIC += "^${PN}-theme-.*"
python populate_packages_prepend() {
- theme_dir = bb.data.expand('${datadir}/themes/', d)
- theme_name = bb.data.expand('${PN}-theme-%s', d)
+ theme_dir = d.expand('${datadir}/themes/')
+ theme_name = d.expand('${PN}-theme-%s')
do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
}
diff --git a/meta-oe/recipes-graphics/pango/pangomm_2.28.2.bb b/meta-oe/recipes-graphics/pango/pangomm_2.28.2.bb
index 2007e9c433..441911395a 100644
--- a/meta-oe/recipes-graphics/pango/pangomm_2.28.2.bb
+++ b/meta-oe/recipes-graphics/pango/pangomm_2.28.2.bb
@@ -8,7 +8,7 @@ PR = "r2"
DEPENDS = "mm-common cairomm glibmm"
-SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pangomm/${SHRT_VER}/pangomm-${PV}.tar.bz2"
SRC_URI[md5sum] = "005a474863495d3c6267429a80da6cf2"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
index 731c490e1b..9103dabfeb 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
@@ -12,7 +12,7 @@ SRC_URI = "http://osdn.dl.sourceforge.jp/mplus-fonts/6650/mplus-TESTFLIGHT-${PV}
S = "${WORKDIR}/mplus-TESTFLIGHT-${PV}"
python populate_packages_prepend() {
- plugindir = bb.data.expand('${datadir}/fonts/ttf-mplus/', d)
+ plugindir = d.expand('${datadir}/fonts/ttf-mplus/')
do_split_packages(d, plugindir, '^(.*)\.ttf$', 'ttf-%s', 'TTF Font %s', extra_depends = "ttf-common")
}