aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-10-19 01:46:12 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-24 08:26:41 +0200
commit4a0066557bcf3af2a9516b523efbfba7387db063 (patch)
tree9ec846b63d594b4b48a32cc4da2e3df270aaaead /meta-oe/recipes-graphics
parenteb66e508e33ccbec8299041265eef183913a3a8c (diff)
downloadmeta-openembedded-4a0066557bcf3af2a9516b523efbfba7387db063.tar.gz
devilspie2: initial add 0.24
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/devilspie/devilspie2_0.24.bb30
-rw-r--r--meta-oe/recipes-graphics/devilspie/files/default.lua46
-rw-r--r--meta-oe/recipes-graphics/devilspie/files/devilspie2.desktop5
3 files changed, 81 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/devilspie/devilspie2_0.24.bb b/meta-oe/recipes-graphics/devilspie/devilspie2_0.24.bb
new file mode 100644
index 0000000000..05311fd545
--- /dev/null
+++ b/meta-oe/recipes-graphics/devilspie/devilspie2_0.24.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Devilspie2 is a window matching utility, allowing the user to perform scripted actions on windows as they are created"
+HOMEPAGE = "http://www.gusnan.se/devilspie2"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=00aefaa50aad75c21367df66102d542c \
+ file://GPL3.txt;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = "gtk+ glib-2.0 libwnck lua5.1 virtual/libx11"
+
+SRC_URI = " \
+ http://www.gusnan.se/devilspie2/download/devilspie2_${PV}-src.tar.gz \
+ file://default.lua \
+ file://devilspie2.desktop \
+"
+SRC_URI[md5sum] = "90b354662659e2922bd051fdde3b0971"
+SRC_URI[sha256sum] = "9c94fa13ed8c0bf6914fdda513e21a4bd527821b97a53d8004168a8d465a646a"
+
+inherit pkgconfig
+
+do_compile() {
+ export GTK2=1
+ oe_runmake CC="${CC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS=" -ldl -lm ${LDFLAGS}"
+}
+
+do_install() {
+ oe_runmake DESTDIR="${D}" PREFIX="${prefix}" install
+ install -d ${D}/${sysconfdir}/devilspie2
+ install -m 644 ${WORKDIR}/default.lua ${D}/${sysconfdir}/devilspie2
+ install -d ${D}/${sysconfdir}/xdg/autostart
+ install -m 644 ${WORKDIR}/devilspie2.desktop ${D}/${sysconfdir}/xdg/autostart
+}
diff --git a/meta-oe/recipes-graphics/devilspie/files/default.lua b/meta-oe/recipes-graphics/devilspie/files/default.lua
new file mode 100644
index 0000000000..22a17fe98e
--- /dev/null
+++ b/meta-oe/recipes-graphics/devilspie/files/default.lua
@@ -0,0 +1,46 @@
+-- Copyright (c) 2012 Andreas Müller <schnitzeltony@googlemail.com>
+--
+-- this is an example
+-- * undecorating all windows opened maximized
+-- * maximizing and undecorating all appplication's windows in apps_list
+-- for further information see
+-- http://www.gusnan.se/devilspie2/manual.php
+
+wnd_type = get_window_type()
+
+if(wnd_type == "WINDOW_TYPE_NORMAL") then
+
+ -- add only applications you want maximized+undecorated and
+ -- which don't keep maximized state
+ apps_list =
+ {
+ "Terminal",
+ "ristretto",
+ "xarchiver",
+ }
+
+ app_name = get_application_name()
+
+ -- to have some informational output, start devilspie2 with --debug
+ -- option and uncomment the following lines:
+
+ --debug_print ("Window Name: " .. get_window_name())
+ --debug_print ("Application name: " .. app_name)
+ --debug_print ("window-type: " .. wnd_type)
+
+ -- undecorate all windows starting maximized
+ if (get_window_is_maximized()) then
+ undecorate_window()
+
+ -- maximize/undecorate all windows in apps_list
+ -- (unfortunately for some also their settings)
+ else
+ for line, str in ipairs(apps_list) do
+ if (string.find(app_name, str)) then
+ maximize()
+ undecorate_window()
+ break
+ end
+ end
+ end
+end
diff --git a/meta-oe/recipes-graphics/devilspie/files/devilspie2.desktop b/meta-oe/recipes-graphics/devilspie/files/devilspie2.desktop
new file mode 100644
index 0000000000..e34e881cd4
--- /dev/null
+++ b/meta-oe/recipes-graphics/devilspie/files/devilspie2.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Type=Application
+Name=Devilspie2
+Exec=devilspie2 -f /etc/devilspie2
+