aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-01-01 13:14:20 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-01 22:34:36 +0100
commit6df498dd5b56ebbc530def20e50a8c53c2911c2b (patch)
tree2c5b1b354bd231ed88d8420b846a9d6fc6515aab /meta-oe/recipes-kernel/ktap/ktap_0.4.bb
parent7348227d40f5bc4c7f6c84f11fecbfc05a4c429d (diff)
downloadmeta-openembedded-6df498dd5b56ebbc530def20e50a8c53c2911c2b.tar.gz
ktap: upgrade to 0.4
* tag v0.3 (and its SRCREV) doesn't exist in any branch so latest bitbake refuses to fetch it Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/ktap/ktap_0.4.bb')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
new file mode 100644
index 0000000000..f5dd62f849
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -0,0 +1,17 @@
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require ktap.inc
+
+SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
+DEPENDS = "ktap-module"
+
+# Only build the userspace app
+EXTRA_OEMAKE = "ktap"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/ktap ${D}${bindir}/
+}
+
+RDEPENDS_${PN} = "kernel-module-ktapvm"
+