aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-09 12:26:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-11 10:46:55 +0100
commit4a680e64f4570d38ffdfca51b67e6347ac91a361 (patch)
treec0f0a64349700c54490948815e3969e2e20d86c7 /meta-oe/recipes-kernel
parentfc591a156abdd880b348bc9433c1d4db602a59f7 (diff)
downloadmeta-openembedded-4a680e64f4570d38ffdfca51b67e6347ac91a361.tar.gz
ktap: add libelf PACKAGECONFIG also to ktap-module
* building ktap-module without elfutils fails with: ktap-module/0.4-r0/git/Makefile:107: No libelf found, disables symbol resolving, please install elfutils-libelf-devel/libelf-dev Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_git.bb5
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc12
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_git.bb10
3 files changed, 14 insertions, 13 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
index e3c94e3dc7..cb913271f6 100644
--- a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
@@ -9,11 +9,8 @@ inherit module
# See https://github.com/ktap/ktap/issues/80
PNBLACKLIST[ktap-module] ?= "Not compatible with 3.19 kernel"
-# Available package configs: ffi (only supported on x86_64)
-PACKAGECONFIG ?= ""
-
# Only build the module
-MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod"
+MAKE_TARGETS = "mod"
# Kernel module packages MUST begin with 'kernel-module-', otherwise
# multilib image generation can fail.
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
index 2c94a08d64..e2e498f9f5 100644
--- a/meta-oe/recipes-kernel/ktap/ktap.inc
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -11,4 +11,16 @@ SRC_URI = "git://github.com/ktap/ktap.git"
S = "${WORKDIR}/git"
# Package config is abused as a general compile time configuration tool.
+
+# Only supports x86_64 for now!. Needs to be enabled for ktap-module too.
PACKAGECONFIG[ffi] = ""
+
+# Needed to resolve symbols in DSO and for sdt
+PACKAGECONFIG[libelf] = ",,elfutils"
+
+PACKAGECONFIG ?= "libelf"
+
+EXTRA_OEMAKE = " \
+ ${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
+ ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
+"
diff --git a/meta-oe/recipes-kernel/ktap/ktap_git.bb b/meta-oe/recipes-kernel/ktap/ktap_git.bb
index 1379c48334..248e7bdd66 100644
--- a/meta-oe/recipes-kernel/ktap/ktap_git.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap_git.bb
@@ -6,17 +6,9 @@ SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
DEPENDS = "ktap-module"
PNBLACKLIST[ktap] ?= "Depends on blacklisted kernel-module-ktapvm"
-#Available package configs:
-# libelf - needed to resolve symbols in DSO and for sdt
-# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
-PACKAGECONFIG ?= "libelf"
-
-PACKAGECONFIG[libelf] = ",,elfutils"
# Only build the userspace app
-EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
- ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
- ktap"
+EXTRA_OEMAKE += "ktap"
do_install() {
install -d ${D}${bindir}