aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-11-16 17:10:11 -0800
committerArmin Kuster <akuster808@gmail.com>2017-11-30 09:13:32 -0800
commitc8913de265ce8f6355ba1f56d034f6ac40596763 (patch)
treee15989ce0bbffbe5ee2dd2150178480a5a79ad13 /meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
parent754754b53bbf4c72d7855e9209f1ccecce5cd8dd (diff)
downloadmeta-openembedded-c8913de265ce8f6355ba1f56d034f6ac40596763.tar.gz
gpsd: use upstream config instead of our own
We have our own versions of the udev, hotplug, and systemd scripts, but at this point they are several years old and were added to fix bugs at the time. As far as I can tell, the relevant bugs are now fixed upstream, so we can move back to the upstream versions. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb12
1 files changed, 4 insertions, 8 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
index 26d74867bf..4c2e328e8a 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
@@ -11,10 +11,6 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
file://0004-SConstruct-disable-html-and-man-docs-building-becaus.patch \
file://0001-include-sys-ttydefaults.h.patch \
- file://gpsd-default \
- file://gpsd \
- file://60-gpsd.rules \
- file://gpsd.service \
"
SRC_URI[md5sum] = "68691b5de4c94f82ec4062b042b5eb63"
SRC_URI[sha256sum] = "03579af13a4d3fe0c5b79fa44b5f75c9f3cac6749357f1d99ce5d38c09bc2029"
@@ -67,13 +63,13 @@ do_install() {
do_install_append() {
install -d ${D}/${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/gpsd ${D}/${sysconfdir}/init.d/
+ install -m 0755 ${S}/packaging/deb/etc_init.d_gpsd ${D}/${sysconfdir}/init.d/gpsd
install -d ${D}/${sysconfdir}/default
- install -m 0644 ${WORKDIR}/gpsd-default ${D}/${sysconfdir}/default/gpsd.default
+ install -m 0644 ${S}/packaging/deb/etc_default_gpsd ${D}/${sysconfdir}/default/gpsd.default
#support for udev
install -d ${D}/${sysconfdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/60-gpsd.rules ${D}/${sysconfdir}/udev/rules.d
+ install -m 0644 ${S}/gpsd.rules ${D}/${sysconfdir}/udev/rules.d/
install -d ${D}${base_libdir}/udev/
install -m 0755 ${S}/gpsd.hotplug ${D}${base_libdir}/udev/
@@ -83,7 +79,7 @@ do_install_append() {
#support for systemd
install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_unitdir}/system/${BPN}.service
+ install -m 0644 ${S}/systemd/${BPN}.service ${D}${systemd_unitdir}/system/${BPN}.service
install -m 0644 ${S}/systemd/${BPN}.socket ${D}${systemd_unitdir}/system/${BPN}.socket
}