aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorFelipe F. Tonello <eu@felipetonello.com>2013-09-24 19:04:56 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:24 +0200
commit595bcead12aa34e48c22f7297aa06f2c0643c04e (patch)
treef04734da5426851aecf0d178a7d978eec7d7fbad /meta-oe/recipes-navigation
parente5da5ebff6dd6964bbeb37a39bbf8afa30ce92da (diff)
downloadmeta-openembedded-595bcead12aa34e48c22f7297aa06f2c0643c04e.tar.gz
geoclue: Add recipe for GeoClue 2.0.0
Geoclue is a D-Bus service that provides location information. The primary goal of the Geoclue project is to make creating location-aware applications as simple as possible, while the secondary goal is to ensure that no application can access location information without explicit permission from user. Signed-off-by: Felipe F. Tonello <eu@felipetonello.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch30
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb32
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch b/meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch
new file mode 100644
index 0000000000..70fe3f55a7
--- /dev/null
+++ b/meta-oe/recipes-navigation/geoclue/files/soup-session-fix.patch
@@ -0,0 +1,30 @@
+Upstream-Status: Upstream-Status: Inappropriate [poky 9.0 has older libsoup]
+
+Signed-off-by: Felipe F. Tonello <eu@felipetonello.com>
+
+diff --git a/src/gclue-ipclient.c b/src/gclue-ipclient.c
+index 09add30..1771d5c 100644
+--- a/src/gclue-ipclient.c
++++ b/src/gclue-ipclient.c
+@@ -83,7 +83,7 @@ gclue_ipclient_init (GClueIpclient *ipclient)
+ {
+ ipclient->priv = G_TYPE_INSTANCE_GET_PRIVATE ((ipclient), GCLUE_TYPE_IPCLIENT, GClueIpclientPrivate);
+
+- ipclient->priv->soup_session = soup_session_new ();
++ ipclient->priv->soup_session = soup_session_sync_new ();
+ }
+
+ /**
+diff --git a/src/geoip-server/geoip-update.c b/src/geoip-server/geoip-update.c
+index 6cce7b2..ef672ba 100644
+--- a/src/geoip-server/geoip-update.c
++++ b/src/geoip-server/geoip-update.c
+@@ -214,7 +214,7 @@ main (int argc, char **argv)
+ path = GEOIP_DATABASE_PATH;
+ }
+
+- session = soup_session_new ();
++ session = soup_session_sync_new ();
+
+ for (i = 0; i < G_N_ELEMENTS (db_info_map); i++) {
+ SoupMessage *msg = NULL;
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb
new file mode 100644
index 0000000000..4a387b5c15
--- /dev/null
+++ b/meta-oe/recipes-navigation/geoclue/geoclue_2.0.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "The Geolocation Service"
+DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
+The primary goal of the Geoclue project is to make creating location-aware applications \
+as simple as possible, while the secondary goal is to ensure that no application \
+can access location information without explicit permission from user."
+LICENSE = "GPLv2.0+"
+SECTION = "console/network"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=8114b83a0435d8136b47bd70111ce5cd"
+
+PR = "r0"
+DEPENDS = "glib-2.0 dbus dbus-glib json-glib libsoup-2.4"
+
+inherit autotools pkgconfig gtk-doc
+
+SRC_URI = " \
+ http://www.freedesktop.org/software/geoclue/releases/2.0/geoclue-${PV}.tar.xz \
+ file://soup-session-fix.patch \
+"
+
+SRC_URI[md5sum] = "401ff99d530b177c62afacef0a33efd9"
+SRC_URI[sha256sum] = "4a82f184e55a163d86e0ad69bbe1bba9960bb5094220fe1f01350bceda8c67a1"
+
+EXTRA_OECONF += " \
+ --with-dbus-service-user=root \
+ --with-dbus-sys-dir=${sysconfdir}/dbus-1/system.d \
+"
+
+FILES_${PN} += " \
+ ${datadir}/dbus-1/system-services/org.freedesktop.GeoClue2.service \
+ ${datadir}/geoclue-2.0/geoclue-interface.xml \
+"