aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-07-11 20:02:06 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:07 +0200
commit87526c2f21b9ae911d74616e0f74b7eef43fa13a (patch)
tree606454c07192ce7b4a01f1f869f78091f710b128 /meta-oe/recipes-navigation
parentfca1dffca771f1c6bdcb859ac4fe2d380ee5f404 (diff)
downloadmeta-openembedded-87526c2f21b9ae911d74616e0f74b7eef43fa13a.tar.gz
gpsd: move systemd support to meta-systemd
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service10
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb15
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb15
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_git.bb14
4 files changed, 12 insertions, 42 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service b/meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service
deleted file mode 100644
index 7131a589d7..0000000000
--- a/meta-oe/recipes-navigation/gpsd/gpsd/gpsd.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=GPS (Global Positioning System) Daemon
-Requires=gpsd.socket
-
-[Service]
-EnvironmentFile=/etc/default/gpsd
-ExecStart=/usr/sbin/gpsd -N $GPS_DEVICES
-
-[Install]
-Also=gpsd.socket
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
index ebc4af6d69..4f3d2d7128 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-native"
PROVIDES = "virtual/gpsd"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
file://0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch \
@@ -15,20 +15,18 @@ SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
file://gpsd-default \
- file://gpsd.service \
file://gpsd \
file://60-gpsd.rules \
"
SRC_URI[md5sum] = "c01353459faa68834309109d4e868460"
SRC_URI[sha256sum] = "79f7de9ead63c7f5d2c9a92e85b5f82e53323c4d451ef8e27ea265ac3ef9a70f"
-inherit scons update-rc.d python-dir systemd
+inherit scons update-rc.d python-dir
INITSCRIPT_NAME = "gpsd"
INITSCRIPT_PARAMS = "defaults 35"
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "${PN}.socket"
+SYSTEMD_OESCONS ??= "false"
export STAGING_INCDIR
export STAGING_LIBDIR
@@ -38,7 +36,7 @@ EXTRA_OESCONS = " \
libQgpsmm='false' \
debug='true' \
strip='false' \
- systemd='true' \
+ systemd='${SYSTEMD_OESCONS}' \
"
# this cannot be used, because then chrpath is not found and only static lib is built
# target=${HOST_SYS}
@@ -81,11 +79,6 @@ do_install_append() {
#support for python
install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
-
- #support for systemd
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service
- install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket
}
pkg_postinst_${PN}-conf() {
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb
index 083163b6d3..3cac186e61 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
DEPENDS = "dbus dbus-glib ncurses python libusb1"
PROVIDES = "virtual/gpsd"
-PR = "r2"
+PR = "r3"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
@@ -16,20 +16,18 @@ SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
file://gpsd-default \
- file://gpsd.service \
file://gpsd \
file://60-gpsd.rules \
"
SRC_URI[md5sum] = "e96881798a0ab67aa3cd5f3249f0e536"
SRC_URI[sha256sum] = "5ebb0b00c49421eb8fbead81342e5ce63e82065e5ff27da586f10e342b999171"
-inherit scons update-rc.d python-dir systemd
+inherit scons update-rc.d python-dir
INITSCRIPT_NAME = "gpsd"
INITSCRIPT_PARAMS = "defaults 35"
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "${PN}.socket"
+SYSTEMD_OESCONS ??= "false"
export STAGING_INCDIR
export STAGING_LIBDIR
@@ -39,7 +37,7 @@ EXTRA_OESCONS = " \
libQgpsmm='false' \
debug='true' \
strip='false' \
- systemd='true' \
+ systemd='${SYSTEMD_OESCONS}' \
"
# this cannot be used, because then chrpath is not found and only static lib is built
# target=${HOST_SYS}
@@ -82,11 +80,6 @@ do_install_append() {
#support for python
install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
-
- #support for systemd
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service
- install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket
}
pkg_postinst_${PN}-conf() {
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_git.bb b/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
index 0cf0685465..1c7d76fa0f 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
DEPENDS = "dbus dbus-glib ncurses python libusb1"
PROVIDES = "virtual/gpsd"
-PR = "r1"
+PR = "r2"
SRCREV = "f8744f4af8cef211de698df5d8e6caddfe33f29d"
@@ -25,13 +25,12 @@ SRC_URI = "git://git.sv.gnu.org/gpsd.git;protocol=git;branch=master \
"
S = "${WORKDIR}/git"
-inherit scons update-rc.d python-dir systemd
+inherit scons update-rc.d python-dir
INITSCRIPT_NAME = "gpsd"
INITSCRIPT_PARAMS = "defaults 35"
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "${PN}.socket"
+SYSTEMD_OESCONS ??= "false"
export STAGING_INCDIR
export STAGING_LIBDIR
@@ -41,7 +40,7 @@ EXTRA_OESCONS = " \
libQgpsmm='false' \
debug='true' \
strip='false' \
- systemd='true' \
+ systemd='${SYSTEMD_OESCONS}' \
"
# this cannot be used, because then chrpath is not found and only static lib is built
# target=${HOST_SYS}
@@ -84,11 +83,6 @@ do_install_append() {
#support for python
install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
-
- #support for systemd
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${S}/systemd/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service
- install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket
}
pkg_postinst_${PN}-conf() {