aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-12-16 22:30:58 -0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-12-21 19:26:41 +0100
commitd74be33220b8161389cb05a8650e328598bbe2ce (patch)
treef267a1fec9dcedb51bf774111f2d6465e51d35ec /meta-oe/recipes-navigation
parent04393f3265221191239109c50827c018119534d6 (diff)
downloadmeta-openembedded-d74be33220b8161389cb05a8650e328598bbe2ce.tar.gz
geos: Update to 3.4.2 and rework the packaging
* This updates to the 3.4.2 release and rework the packaging splitting the C bindings in another binary package to reduce footprint in rootfs; this also moves geos-config to the development package as it should. * Fix -dev installation and upgrade path Using 'lib_package' renames the binaries and we need a transitional package to be used as upgrade path. This is done using an empty 'geos' package which installs the new ones as runtime dependency. This same package is used to satisfy -dev dependency of geos package allowing for its inclusion into SDK. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch39
-rw-r--r--meta-oe/recipes-navigation/geos/geos.inc22
-rw-r--r--meta-oe/recipes-navigation/geos/geos_3.3.2.bb7
-rw-r--r--meta-oe/recipes-navigation/geos/geos_3.4.2.bb6
4 files changed, 56 insertions, 18 deletions
diff --git a/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch b/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch
new file mode 100644
index 0000000000..645e6f62a5
--- /dev/null
+++ b/meta-oe/recipes-navigation/geos/files/geos-config-Add-includedir-variable.patch
@@ -0,0 +1,39 @@
+From 9d51027c228dafd7db2d0cffca1f0fc695e950fd Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Mon, 2 Dec 2013 11:33:26 -0200
+Subject: [PATCH] geos-config: Add includedir variable
+
+This fixes cross-compile as it is easier to mangle the includedir
+during sysroot generation.
+
+Upstream-Status: Pending
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ tools/geos-config.in | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tools/geos-config.in b/tools/geos-config.in
+index 9b45b5f..1749892 100644
+--- a/tools/geos-config.in
++++ b/tools/geos-config.in
+@@ -1,6 +1,7 @@
+ #!/bin/sh
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
++includedir=@includedir@
+ libdir=@libdir@
+
+ usage()
+@@ -38,7 +39,7 @@ case $1 in
+ echo @VERSION@
+ ;;
+ --cflags)
+- echo -I${prefix}/include
++ echo -I${includedir}
+ ;;
+ --libs)
+ # TODO: make an alias for --clibs
+--
+1.7.10.4
+
diff --git a/meta-oe/recipes-navigation/geos/geos.inc b/meta-oe/recipes-navigation/geos/geos.inc
index e0c82bc972..2e308b4882 100644
--- a/meta-oe/recipes-navigation/geos/geos.inc
+++ b/meta-oe/recipes-navigation/geos/geos.inc
@@ -2,20 +2,20 @@ DESCRIPTION = "GEOS - Geometry Engine, Open Source"
HOMEPAGE = "http://trac.osgeo.org/geos/"
SECTION = "libs"
-INC_PR = "r1"
-
LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
SRC_URI = "http://download.osgeo.org/geos/geos-${PV}.tar.bz2"
-inherit autotools pkgconfig
+inherit autotools pkgconfig binconfig
+
+PACKAGES =+ "geoslib ${PN}-c1"
+
+DESCRIPTION_${PN}lib = "Geometry engine for Geographic Information Systems - C++ Library"
+FILES_${PN}lib += "${libdir}/libgeos-${PV}.so"
+
+DESCRIPTION_${PN}-c1 = "Geometry engine for Geographic Information Systems - C Library"
+FILES_${PN}-c1 += "${libdir}/libgeos_c.so.*"
-# libgeos-${PV}.so is needed in PV
-FILES_SOLIBSDEV = ""
-FILES_${PN}-dev = "${libdir}/*.la \
- ${libdir}/libgeos.so \
- ${libdir}/libgeos_c.so \
- ${includedir}"
-FILES_${PN} += " ${libdir}/libgeos-${PV}.so"
-INSANE_SKIP_${PN} = "dev-so"
+ALLOW_EMPTY_${PN} = "1"
+RDEPENDS_${PN} += "geoslib ${PN}-c1"
diff --git a/meta-oe/recipes-navigation/geos/geos_3.3.2.bb b/meta-oe/recipes-navigation/geos/geos_3.3.2.bb
deleted file mode 100644
index e57ca6bcb6..0000000000
--- a/meta-oe/recipes-navigation/geos/geos_3.3.2.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require geos.inc
-
-PR = "${INC_PR}.0"
-
-SRC_URI[md5sum] = "5b7270c73fd1c516f368af8fd1962323"
-SRC_URI[sha256sum] = "ec64d3a92540a1618aa3b91dc1235caae1c370ec23afd59a2734062bf182ed5b"
-
diff --git a/meta-oe/recipes-navigation/geos/geos_3.4.2.bb b/meta-oe/recipes-navigation/geos/geos_3.4.2.bb
new file mode 100644
index 0000000000..3a9a028e8f
--- /dev/null
+++ b/meta-oe/recipes-navigation/geos/geos_3.4.2.bb
@@ -0,0 +1,6 @@
+require geos.inc
+
+SRC_URI += "file://geos-config-Add-includedir-variable.patch"
+
+SRC_URI[md5sum] = "fc5df2d926eb7e67f988a43a92683bae"
+SRC_URI[sha256sum] = "15e8bfdf7e29087a957b56ac543ea9a80321481cef4d4f63a7b268953ad26c53"