aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt
diff options
context:
space:
mode:
authorFelipe F. Tonello <ftonello@cercacor.com>2013-03-19 22:00:33 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-21 22:02:57 +0100
commitac77fd50741b73d820b8b79b025d27350e0f6c90 (patch)
treef98ed34e0285862d1bf6e539f3ebb761e0c7b7a4 /meta-oe/recipes-qt
parentff7a4b13c4efeffc5853a93c6ff7265fa3d6c143 (diff)
downloadmeta-openembedded-ac77fd50741b73d820b8b79b025d27350e0f6c90.tar.gz
fingerterm: Added 1.0.2 recipe
Fingerterm is a terminal emulator for Nokia Harmattan, but it works in any Qt4 environment. Signed-off-by: Felipe F. Tonello <ftonello@cercacor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-qt')
-rw-r--r--meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
new file mode 100644
index 0000000000..9d590fdc68
--- /dev/null
+++ b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "A terminal emulator for Harmattan (Nokia N9/N950) with a custom \
+virtual keyboard and usability-enhancing features such as URL grabber, pan \
+gestures and customizable shortcut menu. Designed especially to be used with \
+screen and irssi."
+HOMEPAGE = "http://hqh.unlink.org/harmattan"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+SECTION = "qt/app"
+
+PR = "r0"
+
+inherit qt4x11 pkgconfig
+
+SRC_URI = " \
+ http://hqh.unlink.org/harmattan/fingerterm-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "d53b0f463c025583cd52accf95715448"
+SRC_URI[sha256sum] = "c21a07cc411d09739bd7fa248eba2bf96427b3f032382a044b6674dd82d95150"
+
+S = "${WORKDIR}/${PN}"
+
+FILES_${PN} = " \
+ ${bindir}/${PN} \
+ ${datadir}/applications/${PN}.desktop \
+ ${datadir}/pixmaps/${PN}.png \
+"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0744 ${S}/${PN} ${D}${bindir}
+
+ sed -i -e '/Exec.*/d' fingerterm.desktop
+ sed -i -e '/Icon.*/d' fingerterm.desktop
+
+ echo 'Exec=${bindir}/${PN}' >> fingerterm.desktop
+ echo 'Icon=${PN}' >> fingerterm.desktop
+
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${S}/${PN}.desktop ${D}${datadir}/applications
+
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 ${S}/${PN}.png ${D}${datadir}/pixmaps
+}