aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/links
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-07-30 23:52:49 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-07-31 00:14:55 +0200
commit4339668ff27c839af1a1e4cfa5a2d034afe204f2 (patch)
treed2a48dca9a2a46a944e5091bf9b157cb2dc15e44 /meta-oe/recipes-support/links
parentf2afdd2b988af8d0b4d822c7c03529b725fe24ba (diff)
downloadmeta-openembedded-4339668ff27c839af1a1e4cfa5a2d034afe204f2.tar.gz
fbreader, fltk, gpm, iksemel, joe, links, ode, openldap, opensync, xchat: import from meta-smartphone
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/links')
-rw-r--r--meta-oe/recipes-support/links/files/ac-prog-cxx.patch11
-rw-r--r--meta-oe/recipes-support/links/files/cookies-save-0.96.patch106
-rw-r--r--meta-oe/recipes-support/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch20
-rw-r--r--meta-oe/recipes-support/links/files/links2.desktop14
-rw-r--r--meta-oe/recipes-support/links/links-x11_2.0+2.1pre30.bb26
-rw-r--r--meta-oe/recipes-support/links/links.inc19
-rw-r--r--meta-oe/recipes-support/links/links_2.0+2.1pre30.bb13
7 files changed, 209 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/links/files/ac-prog-cxx.patch b/meta-oe/recipes-support/links/files/ac-prog-cxx.patch
new file mode 100644
index 0000000000..41c3826850
--- /dev/null
+++ b/meta-oe/recipes-support/links/files/ac-prog-cxx.patch
@@ -0,0 +1,11 @@
+--- links-2.1pre20/configure.in.orig 2005-12-21 15:23:49.000000000 +0000
++++ links-2.1pre20/configure.in 2005-12-21 15:23:59.000000000 +0000
+@@ -18,7 +18,7 @@
+ dnl Checks for programs.
+ AC_PROG_CC
+
+-#AC_PROG_CXX
++AC_PROG_CXX
+ #AC_PROG_AWK
+ #AM_PROG_LEX
+ #AC_PROG_YACC
diff --git a/meta-oe/recipes-support/links/files/cookies-save-0.96.patch b/meta-oe/recipes-support/links/files/cookies-save-0.96.patch
new file mode 100644
index 0000000000..a1e35c01ca
--- /dev/null
+++ b/meta-oe/recipes-support/links/files/cookies-save-0.96.patch
@@ -0,0 +1,106 @@
+diff -ru links-0.96/cookies.c links-0.96+cookies-save/cookies.c
+--- links-0.96/cookies.c Mon Sep 3 07:19:37 2001
++++ links-0.96+cookies-save/cookies.c Mon Sep 3 07:18:42 2001
+@@ -276,15 +276,99 @@
+
+ void init_cookies(void)
+ {
+- /* !!! FIXME: read cookies */
++ unsigned char in_buffer[MAX_STR_LEN];
++ unsigned char *cookfile, *p, *q;
++ FILE *fp;
++
++ /* must be called after init_home */
++ if (! links_home) return;
++
++ cookfile = stracpy(links_home);
++ if (! cookfile) return;
++ add_to_strn(&cookfile, "cookies");
++
++ fp = fopen(cookfile, "r");
++ mem_free(cookfile);
++ if (fp == NULL) return;
++
++ while (fgets(in_buffer, MAX_STR_LEN, fp)) {
++ struct cookie *cookie;
++
++ if (!(cookie = mem_alloc(sizeof(struct cookie)))) return;
++ memset(cookie, 0, sizeof(struct cookie));
++
++ q = in_buffer; p = strchr(in_buffer, ' ');
++ if (p == NULL) goto inv;
++ *p++ = '\0';
++ cookie->name = stracpy(q);
++
++ q = p; p = strchr(p, ' ');
++ if (p == NULL) goto inv;
++ *p++ = '\0';
++ cookie->value = stracpy(q);
++
++ q = p; p = strchr(p, ' ');
++ if (p == NULL) goto inv;
++ *p++ = '\0';
++ cookie->server = stracpy(q);
++
++ q = p; p = strchr(p, ' ');
++ if (p == NULL) goto inv;
++ *p++ = '\0';
++ cookie->path = stracpy(q);
++
++ q = p; p = strchr(p, ' ');
++ if (p == NULL) goto inv;
++ *p++ = '\0';
++ cookie->domain = stracpy(q);
++
++ q = p; p = strchr(p, ' ');
++ if (p == NULL) goto inv;
++ *p++ = '\0';
++ cookie->expires = atoi(q);
++
++ cookie->secure = atoi(p);
++
++ cookie->id = cookie_id++;
++
++ accept_cookie(cookie);
++
++ continue;
++
++inv:
++ free_cookie(cookie);
++ free(cookie);
++ }
++ fclose(fp);
+ }
+
+ void cleanup_cookies(void)
+ {
+ struct cookie *c;
++ unsigned char *cookfile;
++ FILE *fp;
++
+ free_list(c_domains);
+- /* !!! FIXME: save cookies */
+- foreach (c, cookies) free_cookie(c);
++
++ cookfile = stracpy(links_home);
++ if (! cookfile) return;
++ add_to_strn(&cookfile, "cookies");
++
++ fp = fopen(cookfile, "w");
++ mem_free(cookfile);
++ if (fp == NULL) return;
++
++ foreach (c, cookies) {
++ if (c->expires && ! cookie_expired(c))
++ fprintf(fp, "%s %s %s %s %s %d %d\n", c->name, c->value,
++ c->server?c->server:(unsigned char *)"", c->path?c->path:(unsigned char *)"",
++ c->domain?c->domain:(unsigned char *)"", c->expires, c->secure);
++
++ free_cookie(c);
++ }
++
++ fclose(fp);
++
+ free_list(cookies);
+ }
+
diff --git a/meta-oe/recipes-support/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch b/meta-oe/recipes-support/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch
new file mode 100644
index 0000000000..0d3b407e2a
--- /dev/null
+++ b/meta-oe/recipes-support/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch
@@ -0,0 +1,20 @@
+--- links-2.1pre17/cookies.c.pix 2005-05-15 23:05:10.000000000 +0800
++++ links-2.1pre17/cookies.c 2005-05-15 23:17:21.000000000 +0800
+@@ -41,7 +41,7 @@
+
+ void free_cookie(struct cookie *c)
+ {
+- mem_free(c->name);
++ if (c->value) mem_free(c->name);
+ if (c->value) mem_free(c->value);
+ if (c->server) mem_free(c->server);
+ if (c->path) mem_free(c->path);
+@@ -355,7 +355,7 @@
+
+ inv:
+ free_cookie(cookie);
+- free(cookie);
++ mem_free(cookie);
+ }
+ fclose(fp);
+ }
diff --git a/meta-oe/recipes-support/links/files/links2.desktop b/meta-oe/recipes-support/links/files/links2.desktop
new file mode 100644
index 0000000000..a05bce1b2b
--- /dev/null
+++ b/meta-oe/recipes-support/links/files/links2.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Links
+Comment=Links is a browser very similar to lynx
+Comment[es]=El links es un browser para modo texto, similar a lynx
+Comment[pl]=Links jest przeglądarką podobną do lynksa
+Comment[pt]=O links é um browser para modo texto, similar ao lynx
+Comment[pt_BR]=O links é um browser para modo texto, similar ao lynx
+Exec=links -g
+Terminal=true
+Icon=links2
+Type=Application
+Categories=Application;ConsoleOnly;Network;WebBrowser;
+# vi: encoding=utf-8
diff --git a/meta-oe/recipes-support/links/links-x11_2.0+2.1pre30.bb b/meta-oe/recipes-support/links/links-x11_2.0+2.1pre30.bb
new file mode 100644
index 0000000000..b71da9f88e
--- /dev/null
+++ b/meta-oe/recipes-support/links/links-x11_2.0+2.1pre30.bb
@@ -0,0 +1,26 @@
+require links.inc
+
+DEPENDS += "virtual/libx11"
+RCONFLICTS_${PN} = "links"
+
+SRC_URI += " file://links2.desktop \
+ http://www.xora.org.uk/oe/links2.png;name=icon"
+
+EXTRA_OECONF = "--enable-javascript --with-libfl --enable-graphics \
+ --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
+ --without-libtiff --without-svgalib --without-fb \
+ --without-directfb --without-pmshell --without-atheos \
+ --with-x --without-gpm --without-sdl"
+
+do_install_append() {
+ install -d ${D}/${datadir}/applications
+ install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps
+}
+
+
+SRC_URI[md5sum] = "f0f107cc824b71e43f0c6ab620209daf"
+SRC_URI[sha256sum] = "f32314d851e86ec463967ddce78d051e3953b529878cbaeecf882c625ad29c75"
+SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33"
+SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47"
diff --git a/meta-oe/recipes-support/links/links.inc b/meta-oe/recipes-support/links/links.inc
new file mode 100644
index 0000000000..9001d2a3b9
--- /dev/null
+++ b/meta-oe/recipes-support/links/links.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Links is graphics and text mode WWW \
+browser, similar to Lynx."
+HOMEPAGE = "http://links.twibright.com/"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b0c80473f97008e42e29a9f80fcc55ff"
+DEPENDS = "jpeg libpng flex openssl zlib"
+
+LPV = "${@bb.data.getVar("PV",d,1).split("+")[1]}"
+
+SRC_URI = "http://links.twibright.com/download/links-${LPV}.tar.bz2 \
+ file://ac-prog-cxx.patch \
+ file://cookies-save-0.96.patch \
+ file://links-2.1pre17-fix-segfault-on-loading-cookies.patch"
+
+inherit autotools
+
+S = "${WORKDIR}/links-${LPV}"
+
diff --git a/meta-oe/recipes-support/links/links_2.0+2.1pre30.bb b/meta-oe/recipes-support/links/links_2.0+2.1pre30.bb
new file mode 100644
index 0000000000..24961737d1
--- /dev/null
+++ b/meta-oe/recipes-support/links/links_2.0+2.1pre30.bb
@@ -0,0 +1,13 @@
+require links.inc
+
+DEPENDS += "gpm"
+RCONFLICTS_${PN} = "links-x11"
+
+EXTRA_OECONF = "--enable-javascript --with-libfl --enable-graphics \
+ --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
+ --without-libtiff --without-svgalib --with-fb \
+ --without-directfb --without-pmshell --without-atheos \
+ --without-x --without-sdl"
+
+SRC_URI[md5sum] = "f0f107cc824b71e43f0c6ab620209daf"
+SRC_URI[sha256sum] = "f32314d851e86ec463967ddce78d051e3953b529878cbaeecf882c625ad29c75"