aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poppler
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-05-12 20:48:18 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-16 11:04:34 +0200
commitd3fd0666c9b725ece67c18972f18c5d321efccc9 (patch)
tree0113e0c677e21afab4e094969173e6e16c9da3c8 /meta-oe/recipes-support/poppler
parent38e78df3ca443007bee25a2567ca852b52b4f43a (diff)
downloadmeta-openembedded-d3fd0666c9b725ece67c18972f18c5d321efccc9.tar.gz
poppler: fix build for soft FPU machines
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/poppler')
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-splash-Splash.cc-add-cast-to-fix-build-for-enable-fi.patch42
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.22.3.bb7
2 files changed, 47 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-splash-Splash.cc-add-cast-to-fix-build-for-enable-fi.patch b/meta-oe/recipes-support/poppler/poppler/0001-splash-Splash.cc-add-cast-to-fix-build-for-enable-fi.patch
new file mode 100644
index 0000000000..291c7ee178
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler/0001-splash-Splash.cc-add-cast-to-fix-build-for-enable-fi.patch
@@ -0,0 +1,42 @@
+From 8bd7428c28750f682fe3cc1a35291e5696c17638 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Sun, 12 May 2013 18:00:06 +0200
+Subject: [PATCH] splash/Splash.cc: add cast to fix build for
+ --enable-fixedpoint
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+| Splash.cc:1497:30: error: conversion from 'SplashCoord {aka FixedPoint}' to 'Guchar {aka unsigned char}' is ambiguous
+| Splash.cc:1497:30: note: candidates are:
+| In file included from SplashMath.h:27:0,
+| from Splash.cc:44:
+| ../goo/FixedPoint.h:45:3: note: FixedPoint::operator int()
+| ../goo/FixedPoint.h:43:3: note: FixedPoint::operator double()
+| ../goo/FixedPoint.h:41:3: note: FixedPoint::operator float()
+
+Upstream-Status: Submitted [1]
+
+[1] http://lists.freedesktop.org/archives/poppler/2013-May/010247.html
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ splash/Splash.cc | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/splash/Splash.cc b/splash/Splash.cc
+index cd0ec72..6630370 100644
+--- a/splash/Splash.cc
++++ b/splash/Splash.cc
+@@ -1494,7 +1494,7 @@ inline void Splash::drawAALine(SplashPipe *pipe, int x0, int x1, int y) {
+ #endif
+
+ if (t != 0) {
+- pipe->shape = aaGamma[t];
++ pipe->shape = (int)aaGamma[t];
+ (this->*pipe->run)(pipe);
+ updateModX(x);
+ updateModY(y);
+--
+1.7.4.4
+
diff --git a/meta-oe/recipes-support/poppler/poppler_0.22.3.bb b/meta-oe/recipes-support/poppler/poppler_0.22.3.bb
index d3d5ce8073..c8ff8a481f 100644
--- a/meta-oe/recipes-support/poppler/poppler_0.22.3.bb
+++ b/meta-oe/recipes-support/poppler/poppler_0.22.3.bb
@@ -2,9 +2,12 @@ DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code bas
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz"
+SRC_URI = " \
+ http://poppler.freedesktop.org/${PN}-${PV}.tar.gz \
+ file://0001-splash-Splash.cc-add-cast-to-fix-build-for-enable-fi.patch \
+"
SRC_URI[md5sum] = "be915388eaad6865cee5a156c8119ec1"
SRC_URI[sha256sum] = "916a931cbef951366014f13d5f4a574657ccc064ac41051df96dd58e22934431"