aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/toscoterm
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-02-20 19:47:51 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-23 17:57:04 +0100
commit3c50d83184d58eba36f72c7e2e7116d2a8e92a71 (patch)
treedd77760caa8d4d86eef75593984b1ee8118a61db /meta-oe/recipes-support/toscoterm
parenta3d2fd535a2b64d94903ad2127aac103bef02b82 (diff)
downloadmeta-openembedded-3c50d83184d58eba36f72c7e2e7116d2a8e92a71.tar.gz
toscoterm: add
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/toscoterm')
-rw-r--r--meta-oe/recipes-support/toscoterm/toscoterm_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/toscoterm/toscoterm_git.bb b/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
new file mode 100644
index 0000000000..baaac2999d
--- /dev/null
+++ b/meta-oe/recipes-support/toscoterm/toscoterm_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A very small and simple terminal emulator"
+SECTION = "x11/applications"
+DEPENDS = "vte"
+
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://main.c;start_line=5;end_line=16;md5=9ae4bf20caf291afa94530026bd15229"
+
+# 0.2 version
+SRCREV = "8586d617aed19fc75f5ae1e07270752c1b2f9a30"
+SRC_URI = "git://github.com/OSSystems/toscoterm.git"
+
+S = "${WORKDIR}/git"
+
+inherit gitpkgv pkgconfig
+
+do_compile() {
+ oe_runmake \
+ CC="${CC}" \
+ CFLAGS="`pkg-config --cflags vte`${CFLAGS}" \
+ LDFLAGS="`pkg-config --libs vte` ${LDFLAGS}"
+}
+
+do_install() {
+ oe_runmake PREFIX="${prefix}" DESTDIR="${D}" install
+}
+
+RDEPENDS_${PN}_append_libc-glibc += "glibc-gconv-ibm437"