aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/vim
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-06-25 05:36:27 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-15 15:02:27 +0200
commit2f1d7533de0dbaf05e6503d23815d201842b1c76 (patch)
tree678ac97a75bca935a0cf185326148fa5ee7bc1bb /meta-oe/recipes-support/vim
parent8cc44819e8ac1e8431c3b9b9f33613488a3af726 (diff)
downloadmeta-openembedded-2f1d7533de0dbaf05e6503d23815d201842b1c76.tar.gz
vim: work around rpm picking up perl as a dep
Some perl example scripts cause RPM to add perl as a dep, which we don't want, so remove x bit as work around just like the ones for csh and awk. Refer to: 1b088e4 vim: workaround nawk dependency problem with RPM 280d150 vim: workaround a dependency problem with RPM I think a better solution might be: Split the tools directory into a new package ${PN}-tools and add RDEPENDS on csh, awk and perl for it and we don't put it in RRECOMMENDS to install along with vim. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/vim')
-rw-r--r--meta-oe/recipes-support/vim/vim_7.4.258.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/vim/vim_7.4.258.bb b/meta-oe/recipes-support/vim/vim_7.4.258.bb
index 7f88fa0a7d..844be10f88 100644
--- a/meta-oe/recipes-support/vim/vim_7.4.258.bb
+++ b/meta-oe/recipes-support/vim/vim_7.4.258.bb
@@ -60,9 +60,10 @@ EXTRA_OECONF = " \
"
do_install_append() {
- # Work around rpm picking up csh or awk as a dep
+ # Work around rpm picking up csh or awk or perl as a dep
chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/vim132
chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/mve.awk
+ chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/*.pl
# Install example vimrc from runtime files
install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc