aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-04-18 18:16:30 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-21 13:31:47 +0200
commit9dfa0411e01bd23df4994627fa0280c407a1aac9 (patch)
treee511f82f6ef06709e2889a8cd4b4ead66fc45192 /meta-oe/recipes-support
parent797b517efc12b538fdc8a33a24c99b52a294bc9d (diff)
downloadmeta-openembedded-9dfa0411e01bd23df4994627fa0280c407a1aac9.tar.gz
vim: add dependency and selinux and acl support control
1. Add explicit selinux and acl support control. 2. Vim depends on gettext-native, add to the dependency list. 3. Split binary file into vim package and put others in vim-common. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/vim/vim_7.4.258.bb20
1 files changed, 19 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/vim/vim_7.4.258.bb b/meta-oe/recipes-support/vim/vim_7.4.258.bb
index 878c79e74f..023e8fc6c5 100644
--- a/meta-oe/recipes-support/vim/vim_7.4.258.bb
+++ b/meta-oe/recipes-support/vim/vim_7.4.258.bb
@@ -1,6 +1,6 @@
SUMMARY = "Vi IMproved - enhanced vi editor"
SECTION = "console/utils"
-DEPENDS = "ncurses"
+DEPENDS = "ncurses gettext-native"
# vimdiff doesn't like busybox diff
RSUGGESTS_${PN} = "diffutils"
LICENSE = "vim"
@@ -28,11 +28,14 @@ do_configure () {
#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny
PACKAGECONFIG ??= ""
+PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
PACKAGECONFIG[gtkgui] = "--enable-gtk2-test --enable-gui=gtk2,--enable-gui=no,gtk+,"
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
PACKAGECONFIG[x11] = "--with-x,--without-x,xt,"
PACKAGECONFIG[tiny] = "--with-features=tiny,--with-features=big,,"
+PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,"
EXTRA_OECONF = " \
--disable-gpm \
@@ -68,6 +71,21 @@ FILES_${PN}-help = "${datadir}/${PN}/${VIMDIR}/doc"
FILES_${PN}-tutor = "${datadir}/${PN}/${VIMDIR}/tutor ${bindir}/${PN}tutor"
FILES_${PN}-vimrc = "${datadir}/${PN}/vimrc"
FILES_${PN}-data = "${datadir}/${PN}"
+FILES_${PN}-common = " \
+ ${datadir}/${PN}/${VIMDIR}/*.vim \
+ ${datadir}/${PN}/${VIMDIR}/autoload \
+ ${datadir}/${PN}/${VIMDIR}/colors \
+ ${datadir}/${PN}/${VIMDIR}/compiler \
+ ${datadir}/${PN}/${VIMDIR}/ftplugin \
+ ${datadir}/${PN}/${VIMDIR}/indent \
+ ${datadir}/${PN}/${VIMDIR}/keymap \
+ ${datadir}/${PN}/${VIMDIR}/lang \
+ ${datadir}/${PN}/${VIMDIR}/macros \
+ ${datadir}/${PN}/${VIMDIR}/plugin \
+ ${datadir}/${PN}/${VIMDIR}/print \
+ ${datadir}/${PN}/${VIMDIR}/spell \
+ ${datadir}/${PN}/${VIMDIR}/tools \
+"
# Recommend that runtime data is installed along with vim
RRECOMMENDS_${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-data"