aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorTasslehoff Kjappfot <tasskjapp@gmail.com>2012-04-26 23:02:19 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-27 08:55:18 +0200
commit5a3d0de38a3af92d07503184fb214df6e9f57610 (patch)
tree05e212e8560a09241cc1d8ba795b61c93d730681 /meta-oe/recipes-support
parent2bddcd183b9edce8334bcc6cd779373bc8e00c7f (diff)
downloadmeta-openembedded-5a3d0de38a3af92d07503184fb214df6e9f57610.tar.gz
synergy: add synergy 1.3.8
Signed-off-by: Tasslehoff Kjappfot <tasskjapp@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/synergy/synergy_1.3.8.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/synergy/synergy_1.3.8.bb b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
new file mode 100644
index 0000000000..40efcb17a2
--- /dev/null
+++ b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Synergy - control multiple computers with one keyboard and mouse"
+HOMEPAGE = "http://synergy.googlecode.com"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9772a11e3569985855e2ce450e56f991"
+LICENSE = "GPLv2"
+SECTION = "x11/utils"
+
+DEPENDS = "libx11 libxtst"
+
+SRC_URI = "http://synergy.googlecode.com/files/synergy-${PV}-Source.tar.gz"
+
+SRC_URI[md5sum] = "3534c65ecfa6e47d7899c57975442f03"
+SRC_URI[sha256sum] = "0afc83e4ed0b46ed497d4229b2b2854e8d3c581a112f4da05110943edbfacc03"
+
+S = "${WORKDIR}/${PN}-${PV}-Source"
+
+inherit cmake siteinfo
+
+do_install() {
+ install -d ${D}/usr/bin
+ install -m 0755 ${S}/bin/synergy* ${D}/usr/bin/
+}
+