aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-01-28 15:50:13 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:33:24 +0100
commit37a841321dca1314c9844d8d4665b5ff1e28a40f (patch)
treefa18605b97edc9ae7517f0e06489e88e661f5b1e /meta-oe/recipes-support
parent20a624928c030fa13d8b7d45b4f4d7e1ac624f60 (diff)
downloadmeta-openembedded-37a841321dca1314c9844d8d4665b5ff1e28a40f.tar.gz
recipes: add x11 to required DISTRO_FEATURES
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/links/links-x11_2.7.bb4
-rw-r--r--meta-oe/recipes-support/synergy/synergy_1.3.8.bb6
-rw-r--r--meta-oe/recipes-support/utouch/utouch-mtview_git.bb4
3 files changed, 11 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/links/links-x11_2.7.bb b/meta-oe/recipes-support/links/links-x11_2.7.bb
index 87666534e5..2ae11ac97e 100644
--- a/meta-oe/recipes-support/links/links-x11_2.7.bb
+++ b/meta-oe/recipes-support/links/links-x11_2.7.bb
@@ -3,6 +3,10 @@ require links.inc
DEPENDS += "virtual/libx11"
RCONFLICTS_${PN} = "links"
+inherit distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
+
SRC_URI += " file://links2.desktop \
http://www.xora.org.uk/oe/links2.png;name=icon"
diff --git a/meta-oe/recipes-support/synergy/synergy_1.3.8.bb b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
index 642845f967..45c0bc2f52 100644
--- a/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
+++ b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9772a11e3569985855e2ce450e56f991"
LICENSE = "GPL-2.0"
SECTION = "x11/utils"
-DEPENDS = "libx11 libxtst libxinerama"
+DEPENDS = "virtual/libx11 libxtst libxinerama"
SRC_URI = "http://synergy.googlecode.com/files/synergy-${PV}-Source.tar.gz"
@@ -13,7 +13,9 @@ SRC_URI[sha256sum] = "0afc83e4ed0b46ed497d4229b2b2854e8d3c581a112f4da05110943edb
S = "${WORKDIR}/${PN}-${PV}-Source"
-inherit cmake
+inherit cmake distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
do_install() {
install -d ${D}/usr/bin
diff --git a/meta-oe/recipes-support/utouch/utouch-mtview_git.bb b/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
index bcf7e23846..8cb180dc8b 100644
--- a/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
+++ b/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
@@ -5,7 +5,9 @@ HOMEPAGE = "http://bitmath.org/code/mtview/"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=4c61b8950dc1aab4d2aa7c2ae6b1cfb3"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI = "git://bitmath.org/git/mtview.git;protocol=http"
SRCREV = "ad437c38dc111cf3990a03abf14efe1b5d89604b"