aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAsh Charles <ashcharles@gmail.com>2015-01-28 17:30:48 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:33:24 +0100
commit89b48fdf7c5cabb73ffd7492bd45789001f27763 (patch)
tree62f18089b9da123224636605ae402bb9ec3e02f9 /meta-oe/recipes-support
parent717f7f0287057799f2e334f04aa055ba4dfc56f5 (diff)
downloadmeta-openembedded-89b48fdf7c5cabb73ffd7492bd45789001f27763.tar.gz
cpufrequtils: Don't preserve host user permissions
The makefile installs the generated libcpufreq with 'cp -fpR' preserving the user and group of the builder on the host system yielding errors like this: WARNING: log_check: warning: group pulse does not exist - using root Really, this library should be installed with root user and group ownership so override the meaning of 'CP' to simply 'cp'. Signed-off-by: Ash Charles <ashcharles@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb
index e74fa44543..e3b4de1020 100644
--- a/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb
+++ b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb
@@ -22,7 +22,7 @@ S = "${WORKDIR}/git"
TARGET_CC_ARCH += "${LDFLAGS}"
-EXTRA_OEMAKE = "V=1 CROSS=${TARGET_PREFIX} LIBTOOL='${HOST_SYS}-libtool --tag cc' STRIPCMD=echo"
+EXTRA_OEMAKE = "V=1 CROSS=${TARGET_PREFIX} LIBTOOL='${HOST_SYS}-libtool --tag cc' STRIPCMD=echo 'CP=cp'"
do_compile() {
oe_runmake