aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2013-05-22 10:35:37 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 11:01:09 +0200
commit1441aafec850ac3e493030221fd3ee51b242c459 (patch)
tree6705961998455a114d8fb7524634d961480b51aa /meta-oe
parentdd63dc5afda827649555a126c9225982f370ccb0 (diff)
downloadmeta-openembedded-1441aafec850ac3e493030221fd3ee51b242c459.tar.gz
gnuradio : Update recipe to build for all machines.
Also updated the git repo address after recent changes in hosting. The recipe failed to build for machines without neon as a tune feature. The cmake config options have been changed so that it configures properly now. Also dropped documentation from build to work around a doc generation problem. Test on armv7a, x86, and x86-64. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index edd4615aa4..45f4c772f7 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -70,7 +70,7 @@ SRCREV = "5f69899e059e9bea58f92af61f70fc3f63825087"
GIT_REPO = "gnuradio.git"
GIT_BRANCH = "master"
-SRC_URI = "git://gnuradio.org/${GIT_REPO};branch=${GIT_BRANCH};protocol=git \
+SRC_URI = "git://git.gnuradio.org/${GIT_REPO};branch=${GIT_BRANCH};protocol=git \
"
S="${WORKDIR}/git"
@@ -82,21 +82,18 @@ EXTRA_OECMAKE = "-DENABLE_GR_ATSC=FALSE \
-DENABLE_GR_FCD=OFF \
-DENABLE_GR_WXGUI=OFF \
-DENABLE_GR_VIDEO_SDL=OFF \
+ -DENABLE_SPHINX=OFF -DENABLE_DOXYGEN=OFF \
-DIMPORT_EXECUTABLES=${S}/gr-vocoder/lib/generate_codebook.txt \
-DQT_HEADERS_DIR=${STAGING_INCDIR}/qt4 \
-DQT_QTCORE_INCLUDE_DIR=${STAGING_INCDIR}/qt4/QtCore \
-DQT_LIBRARY_DIR=${STAGING_LIBDIR} \
-DQT_QTCORE_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtCore.so \
-DQT_QTGUI_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtGui.so \
+ ${@base_contains('TUNE_FEATURES', 'neon', \
+ '-Dhave_mfpu_neon=1', '-Dhave_mfpu_neon=0', d)} \
"
inherit distutils-base cmake pkgconfig
EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
-# Only builds for machines with neon instructions. Problem is in upstream cmake.
-python () {
- if not oe.utils.contains ('TUNE_FEATURES', 'neon', True, False, d):
- raise bb.parse.SkipPackage("'neon' not in TUNE_FEATURES")
-}
-