aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-19 12:18:18 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-26 10:00:32 +0200
commit87ccfd07de099ec1c95e67b72aa18e2effb77b58 (patch)
tree30c322fb1477d6fb6089e162e97f3838bec0f8d8 /meta-oe
parent265e58da86ee32c86ab52c24b2d8ce4a7cc508a0 (diff)
downloadmeta-openembedded-87ccfd07de099ec1c95e67b72aa18e2effb77b58.tar.gz
llvm2.9: fix build with gcc-4.7
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/llvm/llvm2.9/0035-gcc-4.7.patch16
-rw-r--r--meta-oe/recipes-core/llvm/llvm2.9_2.9.bb2
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm2.9/0035-gcc-4.7.patch b/meta-oe/recipes-core/llvm/llvm2.9/0035-gcc-4.7.patch
new file mode 100644
index 0000000000..4cf8d44640
--- /dev/null
+++ b/meta-oe/recipes-core/llvm/llvm2.9/0035-gcc-4.7.patch
@@ -0,0 +1,16 @@
+Upstream-Status: Pending
+
+Imported from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=673266
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+
+--- a/lib/ExecutionEngine/JIT/Intercept.cpp 2012-05-17 16:11:46.956180361 +0200
++++ b/lib/ExecutionEngine/JIT/Intercept.cpp 2012-05-17 16:14:35.256184996 +0200
+@@ -52,6 +52,7 @@
+ #include <sys/stat.h>
+ #endif
+ #include <fcntl.h>
++#include <unistd.h>
+ /* stat functions are redirecting to __xstat with a version number. On x86-64
+ * linking with libc_nonshared.a and -Wl,--export-dynamic doesn't make 'stat'
+ * available as an exported symbol, so we have to add it explicitly.
diff --git a/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb b/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
index 68cf70bb4d..d5b8c01492 100644
--- a/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
+++ b/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
@@ -2,6 +2,8 @@ require llvm.inc
PR = "${INC_PR}.0"
+SRC_URI += "file://0035-gcc-4.7.patch"
+
SRC_URI_append_libc-uclibc = " file://arm_fenv_uclibc.patch "
PARALLEL_MAKE_virtclass-native = ""