aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-07-13 09:52:45 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-13 12:28:49 +0200
commite8636471d26edce61803b004118b5cce13eaa9aa (patch)
tree143fc23a3775cec0dbb8703c7dab946777215ffb /meta-oe
parent7a8b1010e850b0338f05eacf181e78462355eac6 (diff)
downloadmeta-openembedded-e8636471d26edce61803b004118b5cce13eaa9aa.tar.gz
connman: update to 0.75
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/connman/connman.inc13
-rw-r--r--meta-oe/recipes-connectivity/connman/connman_0.75.bb (renamed from meta-oe/recipes-connectivity/connman/connman_0.74.bb)11
2 files changed, 16 insertions, 8 deletions
diff --git a/meta-oe/recipes-connectivity/connman/connman.inc b/meta-oe/recipes-connectivity/connman/connman.inc
index c0cdf7b4ce..1022ce700e 100644
--- a/meta-oe/recipes-connectivity/connman/connman.inc
+++ b/meta-oe/recipes-connectivity/connman/connman.inc
@@ -43,10 +43,15 @@ do_compile_append() {
do_install_append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
+
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/tools/*-test ${D}${bindir}
+ install -m 0755 ${S}/tools/wispr ${D}${bindir}
+ install -m 0755 ${S}/tools/wifi-scan ${D}${bindir}
}
python populate_packages_prepend() {
- depmap = dict( pppd="ppp", udhcp="busybox connman-scripts", dhclient="dhcp-client", wifi="wpa-supplicant", resolvconf="resolvconf", bluetooth="bluez4", ntpd="ntp" )
+ depmap = dict( pppd="ppp", udhcp="busybox connman-scripts", dhclient="dhcp-client", wifi="wpa-supplicant", resolvconf="resolvconf", bluetooth="bluez4", ntpd="ntp", ofono="ofono" )
packages = []
hook = lambda file,pkg,b,c,d:packages.append((file,pkg))
plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
@@ -62,8 +67,10 @@ python populate_packages_prepend() {
PACKAGES_DYNAMIC = "${PN}-plugin-*"
-PACKAGES += "${PN}-scripts ${PN}-test-utils"
+PACKAGES =+ "${PN}-scripts ${PN}-tools ${PN}-tests"
+FILES_${PN}-tools = "${bindir}/wispr ${bindir}/wifi-scan"
+FILES_${PN{-tests = "${bindir}/*-test"
FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
${sysconfdir} ${sharedstatedir} ${localstatedir} \
${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \
@@ -97,8 +104,6 @@ pkg_postrm_connman-systemd() {
# Needed when using DNS proxy feature
RRECOMMENDS_${PN} += "dnsmasq-dbus"
-FILES_${PN}-test-utils += "${libdir}/connman/test/*"
-
FILES_${PN}-scripts += "${libdir}/connman/scripts"
FILES_${PN}-dbg += "${libdir}/connman/*/.debug"
FILES_${PN}-dev += "${libdir}/connman/*/*.la"
diff --git a/meta-oe/recipes-connectivity/connman/connman_0.74.bb b/meta-oe/recipes-connectivity/connman/connman_0.75.bb
index 7e29487670..827076175c 100644
--- a/meta-oe/recipes-connectivity/connman/connman_0.74.bb
+++ b/meta-oe/recipes-connectivity/connman/connman_0.75.bb
@@ -1,7 +1,5 @@
require connman.inc
-PR = "r1"
-
EXTRA_OECONF += "\
--disable-gtk-doc \
--enable-debug \
@@ -25,5 +23,10 @@ SRC_URI = "\
file://connman \
"
-SRC_URI[md5sum] = "3feb49e7c6dea22de83647cb1790a1b3"
-SRC_URI[sha256sum] = "a283b590bd2ed5c1cd08630cbc7880d9906a3ca763cad121a66c9a5ddfc2882d"
+SRC_URI[md5sum] = "9973cb89a11fff6b51fc85b51c13b711"
+SRC_URI[sha256sum] = "b15361237f7ec8092fb0e55d4585550ab35491485edaf10ddd032d6e36299db7"
+
+# alg-test doesn't build, so disable that
+do_configure_prepend() {
+ sed -i 's:tools/alg-test ::g' Makefile.am
+}