aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2015-11-09 09:34:20 +0800
committerArmin Kuster <akuster808@gmail.com>2015-12-20 14:29:51 -0800
commit96757c3b6d37afc8723b1766d2e92ee0747a6243 (patch)
treef27f14a18ac95506c44ac6cc9cafd68ea7e453b6 /meta-oe
parent5c3aaa9eaf78e6fec10d997a0ecc738b457fba7f (diff)
downloadmeta-openembedded-96757c3b6d37afc8723b1766d2e92ee0747a6243.tar.gz
rrdtool: install python site packages into libdir
Fix the do_configure function to suite the latest version to install python libraries into ${libdir}. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
index 666ace92fc..4d6318cbde 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
@@ -77,8 +77,8 @@ do_configure() {
#remove the dependency of perl-shared:Makefile
#or perl-shared/Makefile will be regenerated
#if any code touch bindings/Makefile after below perl bindings code
- sed -i -e "s:\$(PYTHON) setup.py install:\$(PYTHON) setup.py install \
- --install-lib=${D}${PYTHON_SITEPACKAGES_DIR}:" \
+ sed -i -e "s:python/setup.py install:python/setup.py install \
+ --install-lib=${PYTHON_SITEPACKAGES_DIR}:" \
-e "s:perl-shared/Makefile.PL Makefile:perl-shared/Makefile.PL:" \
${B}/bindings/Makefile
@@ -111,8 +111,8 @@ RDEPENDS_${PN}-perl = "perl perl-module-lib perl-module-getopt-long perl-module-
DESCRIPTION_${PN}-python = \
"The ${PN}-python package includes RRDtool bindings for python."
-FILES_${PN}-python = "${nonarch_libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
+FILES_${PN}-python = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
RDEPENDS_${PN}-python = "python"
FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/RRDs/.debug \
- ${nonarch_libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"
+ ${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"