aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2018-09-30 16:25:28 +0800
committerKhem Raj <raj.khem@gmail.com>2018-09-30 08:42:03 -0700
commit0b663c4f9ae0fc2d6b2d7cda4baff4b00059a52d (patch)
tree0d283e5fd2c2eca9944da0567c898a567a5d50de /meta-oe
parenta5ebab5dfea9683d0073604cf4f622226cfb60fe (diff)
downloadmeta-openembedded-0b663c4f9ae0fc2d6b2d7cda4baff4b00059a52d.tar.gz
rsyslog: avoid recompiling program during running ptest
* Previously there is below logic in rsyslog-8.37.0/tests/Makefile check-TESTS: After below commit in automake, 8555e7b81 check: Make 'check-TESTS' target depend on test dependencies the logic changes to the below: check-TESTS: $(check_PROGRAMS) It will result in compiling program on target when run ptest on target, but actually there is no need to rebuild the program on target, so change it back to "check-TESTS:" to avoid recompiling. * Update the path of abs_top_builddir to guarantee the test env is correct. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_8.37.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_8.37.0.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_8.37.0.bb
index fb151428fd..fbdf2818c1 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_8.37.0.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_8.37.0.bb
@@ -86,10 +86,14 @@ do_install_ptest() {
# do NOT need to rebuild Makefile itself
sed -i 's/^Makefile:.*$/Makefile:/' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
+ # do NOT need to rebuild $(check_PROGRAMS)
+ sed -i 's/^check-TESTS:.*$/check-TESTS:/' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
# fix the srcdir, top_srcdir
sed -i 's,^\(srcdir = \).*,\1${PTEST_PATH}/tests,' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
sed -i 's,^\(top_srcdir = \).*,\1${PTEST_PATH}/tests,' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
+ # fix the abs_top_builddir
+ sed -i 's,^\(abs_top_builddir = \).*,\1${PTEST_PATH}/,' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
# valgrind is not compatible with arm and mips,
# so remove related test cases if there is no valgrind.