aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorJames Feist <james.feist@linux.intel.com>2018-10-04 16:15:37 -0700
committerKhem Raj <raj.khem@gmail.com>2018-10-04 20:00:52 -0700
commit126f046247079aed0fdc2acda21b0f6898b56bd6 (patch)
tree5886165bb3d97aa9045a5c2f6615c7b35ea1f11e /meta-oe
parent7d892a14ef4e03ef916e18ace4505073a36afb1d (diff)
downloadmeta-openembedded-126f046247079aed0fdc2acda21b0f6898b56bd6.tar.gz
nlohmann-json: Add recipe
nlohmann-json is a c++ header-only json library. Signed-off-by: James Feist <james.feist@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
new file mode 100644
index 0000000000..a89b659ae8
--- /dev/null
+++ b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "JSON for modern C++"
+HOMEPAGE = "https://nlohmann.github.io/json/"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=9a8ae1c2d606c432a2aa2e2de15be22a"
+
+SRC_URI = "git://github.com/nlohmann/json.git"
+
+PV = "3.2.0+git${SRCPV}"
+
+SRCREV = "8c20571136f2d5351b379a06ad6591bd980880fe"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
+
+# nlohmann-json is a header only C++ library, so the main package will be empty.
+
+RDEPENDS_${PN}-dev = ""
+
+BBCLASSEXTEND = "native nativesdk"