aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-17 10:21:40 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-19 19:30:45 +0200
commit6e16217af961e080ec14baa07ccb1186402a82e1 (patch)
tree9200027400dd65f3de59d111f83cae5d607c7e17 /meta-oe
parent0c437156db80dbb1758ae7b9116c1f6b048d57b8 (diff)
downloadmeta-openembedded-6e16217af961e080ec14baa07ccb1186402a82e1.tar.gz
tiobench: Fix build with hardening flags
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/0001-Specify-printf-formats.patch49
-rw-r--r--meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/0001-Specify-printf-formats.patch b/meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/0001-Specify-printf-formats.patch
new file mode 100644
index 0000000000..cfd34f02a0
--- /dev/null
+++ b/meta-oe/recipes-benchmark/tiobench/tiobench-0.3.3/0001-Specify-printf-formats.patch
@@ -0,0 +1,49 @@
+From b08e61ef64eece23ce8ffa2784cd3c4f70b6169e Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 17 Jun 2017 08:08:56 -0700
+Subject: [PATCH] Specify printf formats
+
+Fixes
+tiotest.c:555:4: error: format not a string literal and no format arguments [-Werror=format-security]
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ tiotest.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tiotest.c b/tiotest.c
+index 6b3d0c3..3e6166a 100644
+--- a/tiotest.c
++++ b/tiotest.c
+@@ -91,7 +91,7 @@ inline void checkIntZero(int value, char *mess)
+ {
+ if (value <= 0)
+ {
+- printf(mess);
++ printf("%s",mess);
+ printf("Try 'tiotest -h' for more information.\n");
+ exit(1);
+ }
+@@ -101,7 +101,7 @@ inline void checkLong(long value, char *mess)
+ {
+ if (value < 0)
+ {
+- printf(mess);
++ printf("%s", mess);
+ printf("Try 'tiotest -h' for more information\n");
+ exit(1);
+ }
+@@ -552,7 +552,7 @@ void do_test( ThreadTest *test, int testCase, int sequential,
+ if(args.debugLevel > 4)
+ {
+ printf("Created %d threads\n", i);
+- fprintf(stderr, debugMessage);
++ fprintf(stderr, "%s", debugMessage);
+ fflush(stderr);
+ }
+
+--
+2.13.1
+
diff --git a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
index 35af35fd3d..427ce67d61 100644
--- a/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
+++ b/meta-oe/recipes-benchmark/tiobench/tiobench_0.3.3.bb
@@ -10,6 +10,7 @@ SRC_URI = "\
file://tiobench-makefile.patch \
file://avoid-glibc-clashes.patch \
file://0001-Drop-inline-of-crc32-function-to-fix-build-using-GCC.patch \
+ file://0001-Specify-printf-formats.patch \
"
SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128"
SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc"