aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authoriddinev <xidinev@gmail.com>2019-03-19 17:59:52 +0200
committerKhem Raj <raj.khem@gmail.com>2019-03-21 07:53:33 -0700
commit7ed921f8853a0ed8fb60789a107a937137198483 (patch)
treeb0c601da3696c1705df1772e9ea6c31a3815ad9f /meta-oe
parent74bab845c6905ce9cd1c74f237971a6b7aa9e4c8 (diff)
downloadmeta-openembedded-7ed921f8853a0ed8fb60789a107a937137198483.tar.gz
recipes-support/libutempter: Fix the macro string concatenation.
The previous patch 0001-Fix-macro-error.patch erroneously assumes that the 'MACRO1##MACRO2' operation expands the macros before concatination. As a result the UTEMPTER_DEFAULT_PATHNAME always gets the literal RAW_UTEMPTER_PATH value. Signed-off-by: iddinev <xidinev@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter.bb1
-rw-r--r--meta-oe/recipes-support/libutempter/libutempter/0002-Proper-macro-path-generation.patch34
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libutempter/libutempter.bb b/meta-oe/recipes-support/libutempter/libutempter.bb
index 8c84cb376f..b8a700b7b7 100644
--- a/meta-oe/recipes-support/libutempter/libutempter.bb
+++ b/meta-oe/recipes-support/libutempter/libutempter.bb
@@ -12,6 +12,7 @@ PV = "1.1.6-alt2+git${SRCPV}"
SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git \
file://0001-Fix-macro-error.patch \
+ file://0002-Proper-macro-path-generation.patch \
file://libutempter-remove-glibc-assumption.patch \
"
diff --git a/meta-oe/recipes-support/libutempter/libutempter/0002-Proper-macro-path-generation.patch b/meta-oe/recipes-support/libutempter/libutempter/0002-Proper-macro-path-generation.patch
new file mode 100644
index 0000000000..2a866c0796
--- /dev/null
+++ b/meta-oe/recipes-support/libutempter/libutempter/0002-Proper-macro-path-generation.patch
@@ -0,0 +1,34 @@
+From 48b6bcf9f5d8a05eace4bc463c47e8a4715d3000 Mon Sep 17 00:00:00 2001
+From: iddinev <xidinev@gmail.com>
+Date: Mon, 18 Mar 2019 15:45:20 +0200
+Subject: [PATCH] Proper macro path generation.
+
+Signed-off-by: iddinev <xidinev@gmail.com>
+---
+ libutempter/iface.c | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git libutempter/iface.c libutempter/iface.c
+index 27793f0..c1c0ee9 100644
+--- libutempter/iface.c
++++ libutempter/iface.c
+@@ -44,13 +44,12 @@
+ #endif
+
+ #ifdef LIBEXECDIR
+-# define CAT_PATH(DIR1,DIR2) DIR1##DIR2
+-# define RAW_UTEMPTER_PATH CAT_PATH(LIBEXECDIR,/utempter/utempter)
++# define UTEMPTER_DEFAULT_PATHNAME XSTR_PATH(LIBEXECDIR)"/utempter/utempter"
+ #else
+-# define RAW_UTEMPTER_PATH /usr/lib/libtempter/utempter/utempter
++# define UTEMPTER_DEFAULT_PATHNAME STR_PATH(/usr/lib/libtempter/utempter/utempter)
+ #endif
+ #define STR_PATH(RAW_STR) #RAW_STR
+-#define UTEMPTER_DEFAULT_PATHNAME STR_PATH(RAW_UTEMPTER_PATH)
++#define XSTR_PATH(STR) STR_PATH(STR)
+
+ static const char *utempter_pathname;
+ static int saved_fd = -1;
+--
+2.7.4
+