aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAnkit Navik <ankit.tarot@gmail.com>2019-10-19 14:07:07 +0530
committerKhem Raj <raj.khem@gmail.com>2019-10-21 04:44:10 -0700
commita7464eaa69a7ee4734001aab2e232102e7135772 (patch)
tree76daee4283c031cf3b4a6da7e441fcb6a2622043 /meta-oe
parentd6c7b0a33e7758ffa0f0b12b2f7bb475d1b198e5 (diff)
downloadmeta-openembedded-a7464eaa69a7ee4734001aab2e232102e7135772.tar.gz
glfw: Initial recipe for glfw
It adds generic recipe for glfw: a multi-platform library for OpenGL, OpenGL ES, Vulkan, window and input. Signed-off-by: Ankit Navik <ankit.tarot@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/glfw/glfw_3.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/glfw/glfw_3.3.bb b/meta-oe/recipes-core/glfw/glfw_3.3.bb
new file mode 100644
index 0000000000..e3853a201c
--- /dev/null
+++ b/meta-oe/recipes-core/glfw/glfw_3.3.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A multi-platform library for OpenGL, OpenGL ES, Vulkan, window and input"
+HOMEPAGE = "https://www.glfw.org/"
+DESCRIPTION = "GLFW is an Open Source, multi-platform library for OpenGL, \
+OpenGL ES and Vulkan application development. It provides a simple, \
+platform-independent API for creating windows, contexts and surfaces, reading \
+input, handling events, etc."
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=98d93d1ddc537f9b9ea6def64e046b5f"
+SECTION = "lib"
+
+inherit pkgconfig cmake
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/glfw/glfw.git"
+SRCREV = "d25248343e248337284dfbe5ecd1eddbd37ae66d"
+
+EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
+
+DEPENDS = "libpng libglu zlib libxrandr libxinerama libxi libxcursor"
+REQUIRED_DISTRO_FEATURES = "x11"
+
+COMPATIBLE_HOST_libc-musl = "null"