aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-02 14:29:27 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-02 14:29:27 +0200
commitd56c046902e224faaa038d3882927a64316cb39b (patch)
treedde913d9caed0f00912372c5f97e21a96eb4c016 /meta-oe
parentf95ffd6cedb2a0fcad9db1b2d612663a327be87b (diff)
downloadmeta-openembedded-d56c046902e224faaa038d3882927a64316cb39b.tar.gz
v4l-utils: add 0.8.4 release
This provides the 'libv4l' subpackage that is needed for various webcams that aren't allowed to do colourspace conversion inside the kernel anymore (e.g. pwc cams) Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.4.bb b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.4.bb
new file mode 100644
index 0000000000..3252ae3b06
--- /dev/null
+++ b/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_0.8.4.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "v4l2 and IR applications"
+LICENSE = "GPLv2/LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=48da9957849056017dc568bbc43d8975 \
+ file://COPYING.LIB;md5=d749e86a105281d7a44c2328acebc4b0"
+
+DEPENDS = "jpeg"
+
+# libv4l was absorbed into this, let OE know that
+PROVIDES = "libv4l"
+
+SRC_URI = "git://linuxtv.org/v4l-utils.git;protocol=git"
+SRCREV = "v4l-utils-${PV}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D}"
+
+do_compile() {
+ # fix up some ASNEEDED things
+ for i in $(find ${S} -name "Makefile") ; do
+ sed -i 's:-lrt:-lrt -lpthread:g' $i
+ done
+
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install
+}
+
+PACKAGES =+ "rc-keymaps libv4l libv4l-dbg libv4l-dev"
+
+FILES_rc-keymaps = "${sysconfdir}/rc*"
+FILES_${PN} = "${bindir} ${sbindir} ${base_libdir}/udev/rules.d/70-infrared.rules"
+FILES_libv4l += "${libdir}/libv4l/* ${libdir}/*.so.*"
+FILES_libv4l-dbg += "${libdir}/libv4l/.debug"
+FILES_libv4l-dev += "${libdir}/*.so ${includedir}/lib* ${libdir}/pkgconfig/lib*"
+