aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2015-08-11 08:20:26 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:56:27 +0200
commitfa3c0eadb284215b6085e63b43ef22a2a4dc70c1 (patch)
treed950f0d7011e9d6e9db94ef51eff89802e7a5c22 /meta-perl
parent1d6549dc46ed1e3f8fa7e5168a5019f255baf080 (diff)
downloadmeta-openembedded-fa3c0eadb284215b6085e63b43ef22a2a4dc70c1.tar.gz
libclass-method-modifiers-perl: add 2.11 recipe
Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libclass/libclass-method-modifiers-perl_2.11.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libclass/libclass-method-modifiers-perl_2.11.bb b/meta-perl/recipes-perl/libclass/libclass-method-modifiers-perl_2.11.bb
new file mode 100644
index 0000000000..93d6e54301
--- /dev/null
+++ b/meta-perl/recipes-perl/libclass/libclass-method-modifiers-perl_2.11.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Class::Method::Modifiers - provides Moose-like method modifiers"
+DESCRIPTION = "Method modifiers are a convenient feature from the CLOS \
+(Common Lisp Object System) world."
+
+SECTION = "libs"
+
+HOMEPAGE = "https://github.com/moose/Class-Method-Modifiers/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16fd0ec7b73c0e158426f753943f1058"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Class-Method-Modifiers-${PV}.tar.gz"
+SRC_URI[md5sum] = "c6982e9e89325713d5afaff82cfe1744"
+SRC_URI[sha256sum] = "debf979fbd9ac25cc6fe7d1cab81103c60a21f7027d2a9b4bf5cb264e313d392"
+
+S = "${WORKDIR}/Class-Method-Modifiers-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " perl-module-b \
+ perl-module-base \
+ perl-module-carp \
+ perl-module-exporter \
+ perl-module-strict \
+ perl-module-warnings \
+"
+
+BBCLASSEXTEND = "native"