aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2015-05-07 17:28:17 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-13 14:34:24 +0200
commita61450e764bc0e228f9284daa50f02d3abfa0b84 (patch)
tree8e9b6f7578fd092a4df2ed7e483a5c2af5d8d4c1 /meta-python/recipes-connectivity
parent4a75527515f8856846de53211da73cedfb104f3e (diff)
downloadmeta-openembedded-a61450e764bc0e228f9284daa50f02d3abfa0b84.tar.gz
python-thrift: Add recipe.
Direct copy from recipe in meta-cloud-services. Same recipe is also in meta-openstack. GNU Radio (in meta-sdr) will needs this recipe so it seems like time to move the recipe to a central layer. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r--meta-python/recipes-connectivity/python-thrift/python-thrift_0.9.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-connectivity/python-thrift/python-thrift_0.9.2.bb b/meta-python/recipes-connectivity/python-thrift/python-thrift_0.9.2.bb
new file mode 100644
index 0000000000..ec2ea0c0d0
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-thrift/python-thrift_0.9.2.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python bindings for the Apache Thrift RPC system"
+HOMEPAGE = "https://pypi.python.org/pypi/amqp/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=df17a59cc9e1327ec49c2285e13ac477"
+
+SRCNAME = "thrift"
+
+SRC_URI = "https://pypi.python.org/packages/source/t/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "91f1c224c46a257bb428431943387dfd"
+SRC_URI[sha256sum] = "08f665e4b033c9d2d0b6174d869273104362c80e77ee4c01054a74141e378afa"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools