aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-dbus_1.2.4.bb
diff options
context:
space:
mode:
authorWang Xin <wangxin2015.fnst@cn.fujitsu.com>2016-09-11 11:05:30 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-15 10:22:48 +0200
commit94a6bb9ef9d1404f3b27068cb2c39d1195d8c70a (patch)
tree92704c7d4237a4695657d96cb7632cac0545959e /meta-python/recipes-devtools/python/python-dbus_1.2.4.bb
parent29a6cb6a425a80fff4a4ebc94fa5091b8746a1a5 (diff)
downloadmeta-openembedded-94a6bb9ef9d1404f3b27068cb2c39d1195d8c70a.tar.gz
python-dbus: 1.2.0 -> 1.2.4
Upgrade python-dbus from 1.2.0 to 1.2.4. Signed-off-by: Wang Xin <wangxin2015.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-dbus_1.2.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-dbus_1.2.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-dbus_1.2.4.bb b/meta-python/recipes-devtools/python/python-dbus_1.2.4.bb
new file mode 100644
index 0000000000..271b559b77
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-dbus_1.2.4.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Python bindings for the DBus inter-process communication system"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a"
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "7372a588c83a7232b4e08159bfd48fe5"
+SRC_URI[sha256sum] = "e2f1d6871f74fba23652e51d10873e54f71adab0525833c19bad9e99b1b2f9cc"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native"
+PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native"
+
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig"
+
+do_install_append() {
+ # Remove files that clash with python3-dbus; their content is same
+ rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
+}