aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio.inc
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 13:07:31 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:36:28 -0700
commitb3b34496758768d06a18621754492dde730c9423 (patch)
treee3581d6353f5e60d670360b3b6dc529452fceb6d /meta-python/recipes-devtools/python/python-grpcio.inc
parentd9309e44aa1d530c77ced19af1b4d2c5c0dbec6e (diff)
downloadmeta-openembedded-b3b34496758768d06a18621754492dde730c9423.tar.gz
python{,3}-grpcio: update to 1.14.1
Update python-grpcio and add related python3-grpcio recipe for recent features and bug-fixes. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio.inc25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio.inc b/meta-python/recipes-devtools/python/python-grpcio.inc
new file mode 100644
index 0000000000..23d25f7aa5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio.inc
@@ -0,0 +1,25 @@
+DESCRIPTION = "Google gRPC"
+HOMEPAGE = "http://www.grpc.io/"
+SECTION = "devel/python"
+
+DEPENDS_append = "${PYTHON_PN}-protobuf"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-grpcio:"
+SRC_URI_append_class-target = " file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch "
+
+RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
+"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+inherit pypi
+
+SRC_URI[md5sum] = "0987ae2e47b5103de3cacc437874a3c5"
+SRC_URI[sha256sum] = "4bf23666e763ca7ff6010465864e9f088f4ac7ecc1e11abd6f85b250e66b2c05"
+
+CLEANBROKEN = "1"
+
+BBCLASSEXTEND = "native nativesdk"