aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pytest.inc
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 14:21:04 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit1d870c0ee51b11eb42e2533c8bd428e6654ef454 (patch)
tree00687219d16bdfdb3d2a24592e7e4cecea3625b9 /meta-python/recipes-devtools/python/python-pytest.inc
parent273ea761e1446e69c118280266a75737a3d42a85 (diff)
downloadmeta-openembedded-1d870c0ee51b11eb42e2533c8bd428e6654ef454.tar.gz
python-pytest: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
deleted file mode 100644
index 40ca9c2f13..0000000000
--- a/meta-python/recipes-devtools/python/python-pytest.inc
+++ /dev/null
@@ -1,41 +0,0 @@
-SUMMARY = "Simple powerful testing with python"
-HOMEPAGE = "http://pytest.org"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b"
-
-SRC_URI[md5sum] = "d5ef453f723be46d93e0795f3be86c88"
-SRC_URI[sha256sum] = "0d5fe9189a148acc3c3eb2ac8e1ac0742cb7618c084f3d228baaec0c254b318d"
-
-SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
- "
-
-inherit update-alternatives
-
-RDEPENDS_${PN}_class-target += " \
- ${PYTHON_PN}-attrs \
- ${PYTHON_PN}-debugger \
- ${PYTHON_PN}-doctest \
- ${PYTHON_PN}-json \
- ${PYTHON_PN}-pluggy \
- ${PYTHON_PN}-py \
- ${PYTHON_PN}-setuptools \
- ${PYTHON_PN}-six \
- ${PYTHON_PN}-atomicwrites \
- ${PYTHON_PN}-importlib-metadata \
- ${PYTHON_PN}-pathlib2 \
- ${PYTHON_PN}-wcwidth \
- ${PYTHON_PN}-more-itertools \
- ${PYTHON_PN}-packaging \
-"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:"
-
-ALTERNATIVE_${PN} += "py.test pytest"
-
-NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
-ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
-
-ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
-ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
-
-BBCLASSEXTEND = "native nativesdk"