aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pytest
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-19 12:14:12 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-27 07:25:01 -0800
commit597f912aa5fbb5223fa109ed51a24c8ae400b44a (patch)
tree9568eadb611b98b0de2951d91e391c5c4956a25c /meta-python/recipes-devtools/python/python-pytest
parent58e5a63e03b3a2e1f9fc3aecff715bf6ced82d9f (diff)
downloadmeta-openembedded-597f912aa5fbb5223fa109ed51a24c8ae400b44a.tar.gz
meta-openembedded-597f912aa5fbb5223fa109ed51a24c8ae400b44a.tar.bz2
meta-openembedded-597f912aa5fbb5223fa109ed51a24c8ae400b44a.zip
python-pytest: update to version 3.3.1
Update RDEPENDS for latest version Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch15
1 files changed, 9 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
index e283b17c4..06dfcdfc6 100644
--- a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
+++ b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
@@ -1,29 +1,32 @@
-From e2d81009c790b4ebeced8408b6bae78060cabcaf Mon Sep 17 00:00:00 2001
+From 24a901fd17926e8e05be4ed2e01b0113a2e3a852 Mon Sep 17 00:00:00 2001
From: Derek Straka <derek@asterius.io>
-Date: Wed, 5 Jul 2017 09:35:51 -0400
-Subject: [PATCH 1/1] setup.py: remove the setup_requires for setuptools-scm
+Date: Tue, 19 Dec 2017 11:36:39 -0500
+Subject: [PATCH] [PATCH 1/1] setup.py: remove the setup_requires for
+ setuptools-scm
The setup_requires argument forces the download of the egg file for setuptools-scm
during the do_compile phase. This download is incompatible with the typical fetch
and mirror structure. The only usage of scm is the generation of the _version.py
file and in the release tarball it is already correctly created
+Upstream-Status: Inappropriate [oe specific]
+
Signed-off-by: Derek Straka <derek@asterius.io>
---
setup.py | 1 -
1 file changed, 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 751868c..ef6ebf1 100644
+index 3eb38ef..1163202 100644
--- a/setup.py
+++ b/setup.py
-@@ -71,7 +71,6 @@ def main():
+@@ -82,7 +82,6 @@ def main():
keywords="test unittest",
cmdclass={'test': PyTest},
# the following should be enabled for release
- setup_requires=['setuptools-scm'],
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
install_requires=install_requires,
extras_require=extras_require,
- packages=['_pytest', '_pytest.assertion', '_pytest._code', '_pytest.vendored_packages'],
--
2.7.4