aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-smbus.inc
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2017-03-30 09:27:21 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-05 19:28:31 +0200
commitad81891ee769a25a3fae596d4187bc4181805526 (patch)
tree4586dc1e11b301ce7b4b7e7cbd317e0a22bec3b3 /meta-python/recipes-devtools/python/python-smbus.inc
parenta34ab25fc1074593a1f1d9424c5b416e38b595f0 (diff)
downloadmeta-openembedded-ad81891ee769a25a3fae596d4187bc4181805526.tar.gz
python-smbus: upgrade to 3.1.2
Upgrade to 3.1.2 and use Yocto source mirror to follow commit f76fe46e098d ("i2c-tools: point SRC_URI at Yocto source mirrors") in OpenEmbedded cores i2c-tools recipe. With the upgrade to i2c-tools 3.1.2 Python 3 support has been added. To support Python 3 add a common recipe for all common information and one for each supported Python version 2 and 3. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-smbus.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-smbus.inc18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-smbus.inc b/meta-python/recipes-devtools/python/python-smbus.inc
new file mode 100644
index 0000000000..ded30ced99
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-smbus.inc
@@ -0,0 +1,18 @@
+SUMMARY = "Set of i2c tools for linux - Python module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://smbusmodule.c;startline=1;endline=17;md5=fa24df321a520ff8e10f203425ab9fa8"
+
+SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/i2c-tools-${PV}.tar.bz2 \
+"
+SRC_URI[md5sum] = "7104a1043d11a5e2c7b131614eb1b962"
+SRC_URI[sha256sum] = "db5e69f2e2a6e3aa2ecdfe6a5f490b149c504468770f58921c8c5b8a7860a441"
+
+DEPENDS += "i2c-tools"
+
+S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
+
+do_configure_prepend() {
+ # Adjust for OE header rename
+ sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: Module.mk
+ sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: smbusmodule.c
+}