aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-astroid_2.6.5.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-07-21 13:09:50 +0300
committerKhem Raj <raj.khem@gmail.com>2021-07-23 09:47:04 -0700
commit79b3000c83d2484ba8bde36afa30a60552dac362 (patch)
tree79b6aa3e5457f69783fb50a01c7dd1473a92b323 /meta-python/recipes-devtools/python/python3-astroid_2.6.5.bb
parent5902cb9986b9f6c850181b92cd35740effd6ea39 (diff)
downloadmeta-openembedded-79b3000c83d2484ba8bde36afa30a60552dac362.tar.gz
python3-astroid: Upgrade 2.6.2 -> 2.6.5
Upgrade to release 2.6.5: - Fix a crash when there would be a 'TypeError object does not support item assignment' in the code we parse. - Fix a crash when a AttributeInferenceError was raised when failing to find the real name in infer_import_from. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-astroid_2.6.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-astroid_2.6.5.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-astroid_2.6.5.bb b/meta-python/recipes-devtools/python/python3-astroid_2.6.5.bb
new file mode 100644
index 0000000000..513235bd82
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-astroid_2.6.5.bb
@@ -0,0 +1,32 @@
+SUMMARY = "An abstract syntax tree for Python with inference support."
+HOMEPAGE = "https://pypi.python.org/pypi/astroid"
+SECTION = "devel/python"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1"
+
+SRC_URI[sha256sum] = "83e494b02d75d07d4e347b27c066fd791c0c74fc96c613d1ea3de0c82c48168f"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/astroid/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/astroid/__pycache__/test* \
+"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-lazy-object-proxy \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-wrapt \
+ ${PYTHON_PN}-setuptools \
+"
+
+RDEPENDS_${PN}-tests_class-target += "\
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-xml \
+"