aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography-vectors_3.4.8.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2021-09-06 09:17:40 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-07 10:02:11 -0700
commit5609ec473cc8c62682044959e4ef18ef16d9667d (patch)
tree3f10c52bf4ccc112fafe724573c49543d0a5dbd6 /meta-python/recipes-devtools/python/python3-cryptography-vectors_3.4.8.bb
parentbf8625f249c7ed4d8b81c911d382941988c09f7b (diff)
downloadmeta-openembedded-5609ec473cc8c62682044959e4ef18ef16d9667d.tar.gz
python3-cryptography-vectors: upgrade 3.4.7 -> 3.4.8
Changed the version scheme. This will result in us incrementing the major version more frequently, but does not change our existing backwards compatibility policy. BACKWARDS INCOMPATIBLE: The X.509 certificate parser no longer allows negative serial numbers. RFC 5280 has always prohibited these. BACKWARDS INCOMPATIBLE: Invalid ASN.1 found during certificate parsing will raise an error on initial parse rather than when the invalid field is accessed. BACKWARDS INCOMPATIBLE: Values passed to the X.509 PEM parser must be a single PEM payload and will error on extraneous data. Added support for OpenSSL 3.0.0 as a compilation target. Added support for SM3 and SM4, when using OpenSSL 1.1.1. These algorithms are provided for compatibility in regions where they may be required, and are not generally recommended. We now ship manylinux_2_24 wheels, in addition to our manylinux2010 and manylinux2014 wheels. Added rfc4514_attribute_name attribute to x509.NameAttribute, Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography-vectors_3.4.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography-vectors_3.4.8.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography-vectors_3.4.8.bb b/meta-python/recipes-devtools/python/python3-cryptography-vectors_3.4.8.bb
new file mode 100644
index 0000000000..2fb48f3cf7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography-vectors_3.4.8.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Test vectors for the cryptography package."
+HOMEPAGE = "https://cryptography.io/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+
+SRC_URI[sha256sum] = "4c84410257993d3de058b44b777a49e1da2ae35ebea2970a360c7e3aa0f580f2"
+
+PYPI_PACKAGE = "cryptography_vectors"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-cryptography \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+UPSTREAM_CHECK_REGEX = ""