aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-08-14 17:16:43 -0400
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commit05ad45d9372f8d0185564c1f8f392504f94cf9c3 (patch)
tree4829187959cce3745d05ca2a21af58fbdc698dfe /meta-python/recipes-devtools/python/python3-cython_0.28.5.bb
parent7186a251bcd12264defe54a96aab7fd0f00f1847 (diff)
downloadmeta-openembedded-05ad45d9372f8d0185564c1f8f392504f94cf9c3.tar.gz
python-cython: update to version 0.28.5
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cython_0.28.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cython_0.28.5.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb b/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb
new file mode 100644
index 0000000000..2ce6bdbd68
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cython_0.28.5.bb
@@ -0,0 +1,18 @@
+inherit setuptools3
+require python-cython.inc
+
+RDEPENDS_${PN} += "\
+ python3-setuptools \
+"
+
+# running build_ext a second time during install fails, because Python
+# would then attempt to import cythonized modules built for the target
+# architecture.
+DISTUTILS_INSTALL_ARGS += "--skip-build"
+
+do_install_append() {
+ # rename scripts that would conflict with the Python 2 build of Cython
+ mv ${D}${bindir}/cython ${D}${bindir}/cython3
+ mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
+ mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
+}