aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-05-26 03:37:31 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:47 +0200
commitab2ca92e8322549aa3f13af0c903aa80bd6f10ad (patch)
treeae3995da31c010210facb675f5b09d051aaaa0ba /meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb
parentabc5a71c4d216742dc2af4b475136262ac169612 (diff)
downloadmeta-openembedded-ab2ca92e8322549aa3f13af0c903aa80bd6f10ad.tar.gz
python3-pyudev: add a python3 recipe
- Split to a common python-pyudev.inc for python2 and python3 - The contextlib module is moved to python3-lang. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb b/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb
new file mode 100644
index 0000000000..0292555c74
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyudev_0.21.0.bb
@@ -0,0 +1,8 @@
+require python-pyudev.inc
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-lang \
+"
+
+inherit pypi setuptools3
+