aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-websockets_4.0.1.bb
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2018-04-11 11:51:41 +0200
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:12:48 -0700
commitce3b08ccd61292a277dab12bdb43bc3bdb34f969 (patch)
tree9020552fd8b468f5150c29b6673f26ae0d42149c /meta-python/recipes-devtools/python/python3-websockets_4.0.1.bb
parent2b974db822b586715a6f9d7592706f49c0e87e10 (diff)
downloadmeta-openembedded-ce3b08ccd61292a277dab12bdb43bc3bdb34f969.tar.gz
python3-websockets: Add new recipe for v4.0.1 version
Add recipe for python3-websockets v4.0.1. Strictly speaking the package does not require asyncio but instead builds on top of it and it is essential for any work. Make this recipe a native one to allow usage for example in image tests as a websocket client talking to a device under test. Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-websockets_4.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-websockets_4.0.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-websockets_4.0.1.bb b/meta-python/recipes-devtools/python/python3-websockets_4.0.1.bb
new file mode 100644
index 0000000000..414129c59d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-websockets_4.0.1.bb
@@ -0,0 +1,16 @@
+SUMMARY = "An implementation of the WebSocket Protocol (RFC 6455)"
+HOMEPAGE = "https://github.com/aaugustin/websockets"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5070256738c06d2e59adbec1f4057dac"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "9e8c6b3c70def4146d75fbb0f52bdfc7"
+SRC_URI[sha256sum] = "da4d4fbe059b0453e726d6d993760065d69b823a27efc3040402a6fcfe6a1ed9"
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"