aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-03-30 17:39:33 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-30 07:51:38 -0700
commit6eb78d932f29efb52961c045d4b8b2ea4a2bd7f6 (patch)
tree60bfc0b2b6733e917136cba7666cbba38a7fadef /meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
parentce604d453c9d119e992bdcd7e0e0a01960b8d2de (diff)
downloadmeta-openembedded-6eb78d932f29efb52961c045d4b8b2ea4a2bd7f6.tar.gz
python3-wxgtk4: add recipe
Add recipe for python3-wxgtk4 which is a python3 interface to the wxWidgets Cross-platform C++ GUI toolkit. Add patches to * add back build options for oe * fixup build scripts for cross compile * fix sip oevrride functions compile errors Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
new file mode 100644
index 0000000000..af7b51d83b
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Python3 interface to the wxWidgets Cross-platform C++ GUI toolkit."
+HOMEPAGE = "http://www.wxpython.org"
+
+LICENSE = "WXwindows"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce1d18e2d633d41786c0a8dfbc80917"
+
+DEPENDS = "wxwidgets-native wxwidgets"
+
+PYPI_PACKAGE = "wxPython"
+
+SRC_URI += "file://add-back-option-build-base.patch \
+ file://wxgtk-fixup-build-scripts.patch \
+ file://sip-fix-override-functions.patch \
+ "
+SRC_URI[sha256sum] = "00e5e3180ac7f2852f342ad341d57c44e7e4326de0b550b9a5c4a8361b6c3528"
+
+S = "${WORKDIR}/wxPython-${PV}"
+
+inherit pypi setuptools3 pkgconfig
+
+export WX_CONFIG = "${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config"
+
+RDEPENDS:${PN} = "\
+ python3-difflib \
+ python3-image \
+ python3-numpy \
+ python3-pillow \
+ python3-pprint \
+ python3-pycairo \
+ python3-six \
+ python3-xml \
+"