aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-09-02 11:39:10 -0400
committerKhem Raj <raj.khem@gmail.com>2021-09-03 08:35:28 -0700
commit1191076e791a8641209d255d0b8cca44d669ade6 (patch)
treeed68c2aea0304a95e05b212a25e5a537876b858a /meta-python/recipes-devtools/python
parentb1800419769236f7c449630a9fb398e084e81e47 (diff)
downloadmeta-openembedded-1191076e791a8641209d255d0b8cca44d669ade6.tar.gz
python3-pytest-subtests: add recipe
Newer versions of python3-cryptography will rely on the subtests fixture for their ptests. Add this recipe so that cryptography can be given the necessary RDEPENDS when it is upgraded. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-subtests_0.5.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-subtests_0.5.0.bb b/meta-python/recipes-devtools/python/python3-pytest-subtests_0.5.0.bb
new file mode 100644
index 0000000000..2e03512bde
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-subtests_0.5.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "unittest subTest() support and subtests fixture."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=242b4e17fa287dcf7aef372f6bc3dcb1"
+
+SRC_URI[sha256sum] = "5bd1e4bf0eda4c89a6cd42b0ee28e1d2ca0848de3fd67ad8cdd6d559ed00f120"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"