aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-05-19 12:52:56 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:42 +0200
commit27f872142d7da625286d929d341bb82ee240d621 (patch)
tree1abb02ab8b81f73bdbfc30f3896aded6cfebb31c /meta-python/recipes-devtools/python
parent38d11cb2932e53a07b44c989fb5f54cb13cbd11f (diff)
downloadmeta-openembedded-27f872142d7da625286d929d341bb82ee240d621.tar.gz
python3-zopeinterface: add python3 packaging
Matching what has been done with other python packages, move the existing recipe into a .inc file and then create python and python3 specific bb files to allow the generation of python2 or python3 versions. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-zopeinterface.inc20
-rw-r--r--meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb21
-rw-r--r--meta-python/recipes-devtools/python/python3-zopeinterface_4.3.3.bb4
3 files changed, 25 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python-zopeinterface.inc b/meta-python/recipes-devtools/python/python-zopeinterface.inc
new file mode 100644
index 0000000000..1ea6114634
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-zopeinterface.inc
@@ -0,0 +1,20 @@
+SUMMARY = "Interface definitions for Zope products"
+LICENSE = "ZPL-2.1"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e54fd776274c1b7423ec128974bd9d46"
+
+SRC_URI[md5sum] = "ba3f32eacaea66094b7e2ae2788cec89"
+SRC_URI[sha256sum] = "8780ef68ca8c3fe1abb30c058a59015129d6e04a6b02c2e56b9c7de6078dfa88"
+
+PYPI_PACKAGE = "zope.interface"
+
+PACKAGES =. "${PN}-test "
+
+RPROVIDES_${PN} += "zope-interfaces"
+
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
+FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
+FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
+FILES_${PN}-test += " \
+ ${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \
+ ${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \
+"
diff --git a/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb b/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb
index 8ad1250822..1bdfd4d376 100644
--- a/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb
+++ b/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb
@@ -1,23 +1,4 @@
-SUMMARY = "Interface definitions for Zope products"
-LICENSE = "ZPL-2.1"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e54fd776274c1b7423ec128974bd9d46"
-
-SRC_URI[md5sum] = "ba3f32eacaea66094b7e2ae2788cec89"
-SRC_URI[sha256sum] = "8780ef68ca8c3fe1abb30c058a59015129d6e04a6b02c2e56b9c7de6078dfa88"
-
-PYPI_PACKAGE = "zope.interface"
inherit pypi setuptools
-
-PACKAGES =. "${PN}-test "
-
-RPROVIDES_${PN} += "zope-interfaces"
+require python-zopeinterface.inc
RDEPENDS_${PN}-test += "python-unittest python-doctest"
-
-FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
-FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
-FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
-FILES_${PN}-test += " \
- ${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \
- ${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \
-"
diff --git a/meta-python/recipes-devtools/python/python3-zopeinterface_4.3.3.bb b/meta-python/recipes-devtools/python/python3-zopeinterface_4.3.3.bb
new file mode 100644
index 0000000000..be11858d34
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-zopeinterface_4.3.3.bb
@@ -0,0 +1,4 @@
+inherit pypi setuptools3
+require python-zopeinterface.inc
+
+RDEPENDS_${PN}-test += "python3-unittest python3-doctest"