aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-09-17 05:22:35 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-17 08:36:19 -0700
commit50b9128ed0910e8a4639f9cf62dde18250650bbe (patch)
treee4bc4202aa0a90aed82eabbd88edf7a7df0735fe /meta-python/recipes-devtools/python
parent5eb46e36a66836f6bbc8a0ffd54ae8a7c10a841f (diff)
downloadmeta-openembedded-50b9128ed0910e8a4639f9cf62dde18250650bbe.tar.gz
python3-beautifulsoup4: upgrade 4.9.3 -> 4.10.0
= 4.10.0 (20210907) * This is the first release of Beautiful Soup to only support Python 3. I dropped Python 2 support to maintain support for newer versions (58 and up) of setuptools. See: https://github.com/pypa/setuptools/issues/2769 [bug=1942919] * The behavior of methods like .get_text() and .strings now differs depending on the type of tag. The change is visible with HTML tags like <script>, <style>, and <template>. Starting in 4.9.0, methods like get_text() returned no results on such tags, because the contents of those tags are not considered 'text' within the document as a whole. But a user who calls script.get_text() is working from a different definition of 'text' than a user who calls div.get_text()--otherwise there would be no need to call script.get_text() at all. In 4.10.0, the contents of (e.g.) a <script> tag are considered 'text' during a get_text() call on the tag itself, but not considered 'text' during a get_text() call on the tag's parent. Because of this change, calling get_text() on each child of a tag may now return a different result than calling get_text() on the tag itself. That's because different tags now have different understandings of what counts as 'text'. [bug=1906226] [bug=1868861] * NavigableString and its subclasses now implement the get_text() method, as well as the properties .strings and .stripped_strings. These methods will either return the string itself, or nothing, so the only reason to use this is when iterating over a list of mixed Tag and NavigableString objects. [bug=1904309] * The 'html5' formatter now treats attributes whose values are the empty string as HTML boolean attributes. Previously (and in other formatters), an attribute value must be set as None to be treated as a boolean attribute. In a future release, I plan to also give this behavior to the 'html' formatter. Patch by Isaac Muse. [bug=1915424] * The 'replace_with()' method now takes a variable number of arguments, and can be used to replace a single element with a sequence of elements. Patch by Bill Chandos. [rev=605] * Corrected output when the namespace prefix associated with a namespaced attribute is the empty string, as opposed to None. [bug=1915583] * Performance improvement when processing tags that speeds up overall tree construction by 2%. Patch by Morotti. [bug=1899358] * Corrected the use of special string container classes in cases when a single tag may contain strings with different containers; such as the <template> tag, which may contain both TemplateString objects and Comment objects. [bug=1913406] * The html.parser tree builder can now handle named entities found in the HTML5 spec in much the same way that the html5lib tree builder does. Note that the lxml HTML tree builder doesn't handle named entities this way. [bug=1924908] * Added a second way to pass specify encodings to UnicodeDammit and EncodingDetector, based on the order of precedence defined in the HTML5 spec, starting at: https://html.spec.whatwg.org/multipage/parsing.html#parsing-with-a-known-character-encoding Encodings in 'known_definite_encodings' are tried first, then byte-order-mark sniffing is run, then encodings in 'user_encodings' are tried. The old argument, 'override_encodings', is now a deprecated alias for 'known_definite_encodings'. This changes the default behavior of the html.parser and lxml tree builders, in a way that may slightly improve encoding detection but will probably have no effect. [bug=1889014] * Improve the warning issued when a directory name (as opposed to the name of a regular file) is passed as markup into the BeautifulSoup constructor. [bug=1913628] Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-beautifulsoup4_4.10.0.bb (renamed from meta-python/recipes-devtools/python/python3-beautifulsoup4_4.9.3.bb)5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.9.3.bb b/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.10.0.bb
index cf92c8e9cf..ba89e9db33 100644
--- a/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.9.3.bb
+++ b/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.10.0.bb
@@ -3,8 +3,7 @@ HOMEPAGE = " https://www.crummy.com/software/BeautifulSoup/bs4"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING.txt;md5=f2d38d8a40bf73fd4b3d16ca2e5882d1"
-SRC_URI[md5sum] = "57fd468ae3eb055f6871106e8f7813e2"
-SRC_URI[sha256sum] = "84729e322ad1d5b4d25f805bfa05b902dd96450f43842c4e99067d5e1369eb25"
+SRC_URI[sha256sum] = "c23ad23c521d818955a4151a67d81580319d4bf548d3d49f4223ae041ff98891"
inherit pypi setuptools3
@@ -12,6 +11,8 @@ RDEPENDS:${PN} = "\
${PYTHON_PN}-html5lib \
${PYTHON_PN}-lxml \
${PYTHON_PN}-soupsieve \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-logging \
"
BBCLASSEXTEND = "native nativesdk"