aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-31 20:13:48 +0300
committerKhem Raj <raj.khem@gmail.com>2021-06-01 07:48:10 -0700
commit698890b9ba701f971c86a6bbdede432ad5f877b5 (patch)
tree816d225fe1a1f3ba5927a6fcdefeae630de3dc43 /meta-python/recipes-devtools/python
parent009003055b5713e5223ad01d4daa0aa5cca152ec (diff)
downloadmeta-openembedded-698890b9ba701f971c86a6bbdede432ad5f877b5.tar.gz
python3-astroid: Upgrade 2.5.6 -> 2.5.7
Upgrade to release 2.5.7: - Fix six.with_metaclass transformation so it doesn't break user defined transformations - Fix detection of relative imports - Fix inference of instance attributes defined in base classes - Update `infer_named_tuple` brain to reject namedtuple definitions that would raise ValueError - Do not set instance attributes on builtin object() - Fix some spurious cycles detected in ``context.path`` leading to more cases that can now be inferred - Add ``kind`` field to ``Const`` nodes, matching the structure of the built-in ast Const. The kind field is "u" if the literal is a u-prefixed string, and ``None`` otherwise. - Fix property inference in class contexts for properties defined on the metaclass - Update enum brain to fix definition of __members__ for subclass-defined Enums - Update random brain to fix a crash with inference of some sequence elements - Fix inference of attributes defined in a base class that is an inner class - Allow inferring a return value of None for non-abstract empty functions and functions with no return statements (implicitly returning None) - scm_setuptools has been added to the packaging. - Astroid's tags are now the standard form ``vX.Y.Z`` and not ``astroid-X.Y.Z`` anymore. - Add initial support for Pattern Matching in Python 3.10 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-astroid_2.5.7.bb (renamed from meta-python/recipes-devtools/python/python3-astroid_2.5.6.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-astroid_2.5.6.bb b/meta-python/recipes-devtools/python/python3-astroid_2.5.7.bb
index 62c54a46b9..c805dc4dc9 100644
--- a/meta-python/recipes-devtools/python/python3-astroid_2.5.6.bb
+++ b/meta-python/recipes-devtools/python/python3-astroid_2.5.7.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1"
-SRC_URI[sha256sum] = "8a398dfce302c13f14bab13e2b14fe385d32b73f4e4853b9bdfb64598baa1975"
+SRC_URI[sha256sum] = "d66a600e1602736a0f24f725a511b0e50d12eb18f54b31ec276d2c26a0a62c6a"
inherit pypi setuptools3