aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorParthiban Nallathambi <parthitce@gmail.com>2019-05-01 19:06:59 +0200
committerKhem Raj <raj.khem@gmail.com>2019-05-03 10:04:45 -0700
commit71dd99f91ca4366300faba133b4f641ef072709f (patch)
tree8bf4698e7d6ca04fefff9c8f8fbac2ecc5467715 /meta-python/recipes-devtools/python
parent5f4c4407d807035c799eed968d9d69e1aa08581c (diff)
downloadmeta-openembedded-71dd99f91ca4366300faba133b4f641ef072709f.tar.gz
python3-sentry-sdk: add version 0.7.14
Signed-off-by: Parthiban Nallathambi <parthitce@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-sentry-sdk.inc12
-rw-r--r--meta-python/recipes-devtools/python/python3-sentry-sdk_0.7.14.bb2
2 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-sentry-sdk.inc b/meta-python/recipes-devtools/python/python-sentry-sdk.inc
new file mode 100644
index 0000000000..0c123cef48
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sentry-sdk.inc
@@ -0,0 +1,12 @@
+SUMMARY = "The new Python SDK for Sentry.io"
+DESCRIPTION = "This is the next line of the Python SDK \
+for Sentry, intended to replace the raven package on PyPI."
+HOMEPAGE = "https://github.com/getsentry/sentry-python"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0c79f8d3c91fc847350efd28bfe0a341"
+
+SRC_URI[md5sum] = "fef016d075137c4fb8724559cad28b86"
+SRC_URI[sha256sum] = "5818289868755cfea74e61e532b4b0d11d523901041338d473277db91d4d8173"
+
+PYPI_PACKAGE = "sentry-sdk"
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python3-sentry-sdk_0.7.14.bb b/meta-python/recipes-devtools/python/python3-sentry-sdk_0.7.14.bb
new file mode 100644
index 0000000000..840df93404
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sentry-sdk_0.7.14.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-sentry-sdk.inc