aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorBill Randle <bill.randle@gmail.com>2017-12-07 21:49:04 -0800
committerArmin Kuster <akuster808@gmail.com>2017-12-22 19:43:54 -0800
commit875913e5141da3c33cf661e153cc86c2093eadd8 (patch)
treecb68aca4ff082d4ac3184596b6f35a61d95c8cb8 /meta-python/recipes-devtools/python
parentf231401c44adf3b13ee3960ea7bad4e75af8abe2 (diff)
downloadmeta-openembedded-875913e5141da3c33cf661e153cc86c2093eadd8.tar.gz
python[3]-flask-script: new recipes
Signed-off-by: Bill Randle <bill.randle@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-flask-script.inc12
-rw-r--r--meta-python/recipes-devtools/python/python-flask-script_2.0.6.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb2
3 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-script.inc b/meta-python/recipes-devtools/python/python-flask-script.inc
new file mode 100644
index 0000000000..fca777bc55
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-script.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "Scripting support for flask"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e686048adb69341fc8a08caeda528b41"
+
+SRC_URI[md5sum] = "3fbd91fe13cebedfb2431331f6eabb68"
+SRC_URI[sha256sum] = "6425963d91054cfcc185807141c7314a9c5ad46325911bd24dcb489bd0161c65"
+
+PYPI_PACKAGE = "Flask-Script"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-flask \
+ "
diff --git a/meta-python/recipes-devtools/python/python-flask-script_2.0.6.bb b/meta-python/recipes-devtools/python/python-flask-script_2.0.6.bb
new file mode 100644
index 0000000000..b7d55af151
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-script_2.0.6.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-flask-script.inc
diff --git a/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb b/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb
new file mode 100644
index 0000000000..9f885191be
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-script_2.0.6.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-flask-script.inc