aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-03-28 14:21:33 +0800
committerKhem Raj <raj.khem@gmail.com>2019-03-28 11:56:25 -0700
commita88f90fb8de86adbca8e7a65a510899bd0929b48 (patch)
tree63c7c19ac122c9bda8b202959c837ac43bd0fdc5 /meta-python/recipes-devtools/python
parentbd051518cc3a5e408a7b4650869b2ca1a480e6c9 (diff)
downloadmeta-openembedded-a88f90fb8de86adbca8e7a65a510899bd0929b48.tar.gz
python-tqdm: add recipe
Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-tqdm.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-tqdm_4.31.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-tqdm_4.31.1.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-tqdm.inc b/meta-python/recipes-devtools/python/python-tqdm.inc
new file mode 100644
index 0000000000..967a80c20e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-tqdm.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Fast, Extensible Progress Meter"
+HOMEPAGE = "http://tqdm.github.io/"
+SECTION = "devel/python"
+
+LICENSE = "MIT & MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=054ef7105cba050017d1368262a1623c"
+
+inherit pypi
+
+SRC_URI[md5sum] = "807e8c13e16e3660ac88e05d711daeb0"
+SRC_URI[sha256sum] = "e22977e3ebe961f72362f6ddfb9197cc531c9737aaf5f607ef09740c849ecd05"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-tqdm_4.31.1.bb b/meta-python/recipes-devtools/python/python-tqdm_4.31.1.bb
new file mode 100644
index 0000000000..b3810097e6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-tqdm_4.31.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-tqdm.inc
diff --git a/meta-python/recipes-devtools/python/python3-tqdm_4.31.1.bb b/meta-python/recipes-devtools/python/python3-tqdm_4.31.1.bb
new file mode 100644
index 0000000000..348337f0d6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tqdm_4.31.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-tqdm.inc