aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2019-04-15 13:57:13 +0800
committerKhem Raj <raj.khem@gmail.com>2019-04-16 21:07:25 -0700
commitcb224dcd7f7a24ffd802a206f3f453850d7a1328 (patch)
tree0c705f88622aa0443cc9fd9d9f6288dad34bcae4 /meta-python/recipes-devtools/python
parent102237efa6a34efca82f8496d12898f27e813092 (diff)
downloadmeta-openembedded-cb224dcd7f7a24ffd802a206f3f453850d7a1328.tar.gz
To fix confilict error with python3-pbr.
Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pbr_4.2.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pbr_4.2.0.bb b/meta-python/recipes-devtools/python/python-pbr_4.2.0.bb
index 32487723b1..361f2a4b56 100644
--- a/meta-python/recipes-devtools/python/python-pbr_4.2.0.bb
+++ b/meta-python/recipes-devtools/python/python-pbr_4.2.0.bb
@@ -5,3 +5,9 @@ require recipes-devtools/python/python-pbr.inc
SRC_URI[md5sum] = "6619780896ca81c7cd19c6e2f439b6c9"
SRC_URI[sha256sum] = "1b8be50d938c9bb75d0eaf7eda111eec1bf6dc88a62a6412e33bf077457e0f45"
+do_install_append() {
+ if [ -f ${D}${bindir}/pbr ]; then
+ mv ${D}${bindir}/pbr ${D}${bindir}/pbr-2
+ fi
+}
+